aboutsummarylogtreecommitdiffstats
path: root/usd_python.patch
diff options
context:
space:
mode:
authorbartus2020-05-04 02:56:24 +0200
committerbartus2020-05-04 03:33:58 +0200
commita70cc33f4191d13036c801abf56fc6e5cdc47e32 (patch)
tree587e27931332a149495bc59e6d8840e77232bd3f /usd_python.patch
parentde41018f24f6b7b7917aa34deae90eb4b652b358 (diff)
downloadaur-a70cc33f4191d13036c801abf56fc6e5cdc47e32.tar.gz
Refactor.
Diffstat (limited to 'usd_python.patch')
-rw-r--r--usd_python.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/usd_python.patch b/usd_python.patch
new file mode 100644
index 000000000000..a72d75cd6f0e
--- /dev/null
+++ b/usd_python.patch
@@ -0,0 +1,26 @@
+diff --git a/build_files/cmake/platform/platform_unix.cmake b/build_files/cmake/platform/platform_unix.cmake
+index ac570f17e47..505aa97934c 100644
+--- a/build_files/cmake/platform/platform_unix.cmake
++++ b/build_files/cmake/platform/platform_unix.cmake
+@@ -320,6 +320,9 @@ if(WITH_BOOST)
+ if(WITH_OPENVDB)
+ list(APPEND __boost_packages iostreams)
+ endif()
++ if(WITH_USD)
++ list(APPEND __boost_packages python27)
++ endif()
+ list(APPEND __boost_packages system)
+ find_package(Boost 1.48 COMPONENTS ${__boost_packages})
+ if(NOT Boost_FOUND)
+diff --git a/source/blender/usd/CMakeLists.txt b/source/blender/usd/CMakeLists.txt
+index 6ea02f44d76..0ec18e17689 100644
+--- a/source/blender/io/usd/CMakeLists.txt
++++ b/source/blender/io/usd/CMakeLists.txt
+@@ -48,6 +48,7 @@ set(INC
+ set(INC_SYS
+ ${USD_INCLUDE_DIRS}
+ ${BOOST_INCLUDE_DIR}
++ ${PYTHON_INCLUDE_DIRS}
+ ${TBB_INCLUDE_DIR}
+ )
+