summarylogtreecommitdiffstats
path: root/use-system-libs.patch
diff options
context:
space:
mode:
authorAlexandre Bouvier2023-04-09 14:32:12 +0200
committerAlexandre Bouvier2023-04-09 14:32:12 +0200
commit5731c7880c315cda4c7b504c548cb21f06e63289 (patch)
treed2336b5995c86ce67769b5abab55af27921ffbe8 /use-system-libs.patch
parent942ab58c65cfc0c90521ae39358f972161862a9e (diff)
downloadaur-5731c7880c315cda4c7b504c548cb21f06e63289.tar.gz
use system libs
Diffstat (limited to 'use-system-libs.patch')
-rw-r--r--use-system-libs.patch75
1 files changed, 75 insertions, 0 deletions
diff --git a/use-system-libs.patch b/use-system-libs.patch
new file mode 100644
index 000000000000..340d0e7b4699
--- /dev/null
+++ b/use-system-libs.patch
@@ -0,0 +1,75 @@
+diff --git a/cmake/BuildParameters.cmake b/cmake/BuildParameters.cmake
+index 907d23e52..cbed1bfd4 100644
+--- a/cmake/BuildParameters.cmake
++++ b/cmake/BuildParameters.cmake
+@@ -17,14 +17,12 @@ if(LIBRETRO)
+ set(USE_DISCORD_PRESENCE FALSE)
+ set(USE_ACHIEVEMENTS OFF)
+ set(QT_BUILD OFF)
+- set(USE_SYSTEM_LIBS OFF)
+ add_definitions(-D__LIBRETRO__)
+ endif()
+ optional_system_library(fmt)
+ optional_system_library(ryml)
+ optional_system_library(zstd)
+ optional_system_library(libzip)
+-optional_system_library(SDL2)
+ option(LTO_PCSX2_CORE "Enable LTO/IPO/LTCG on the subset of pcsx2 that benefits most from it but not anything else")
+
+ option(USE_VTUNE "Plug VTUNE to profile GS JIT.")
+diff --git a/cmake/SearchForStuff.cmake b/cmake/SearchForStuff.cmake
+index 35b207f2e..7184675b6 100644
+--- a/cmake/SearchForStuff.cmake
++++ b/cmake/SearchForStuff.cmake
+@@ -76,7 +76,6 @@ else()
+ check_lib(SOUNDTOUCH SoundTouch SoundTouch.h PATH_SUFFIXES soundtouch)
+
+ if(NOT QT_BUILD AND NOT APPLE)
+- find_optional_system_library(SDL2 3rdparty/sdl2 2.0.12)
+ endif()
+
+ if(UNIX AND NOT APPLE)
+@@ -87,7 +86,6 @@ else()
+ find_package(Wayland REQUIRED)
+ endif()
+
+- find_package(Libbacktrace)
+ endif()
+ endif(WIN32)
+
+@@ -173,8 +171,7 @@ if(NOT WIN32 AND QT_BUILD)
+ find_package(CURL REQUIRED)
+ endif()
+
+-add_subdirectory(3rdparty/lzma EXCLUDE_FROM_ALL)
+-add_subdirectory(3rdparty/libchdr EXCLUDE_FROM_ALL)
++check_lib(LIBCHDR libchdr libchdr/chd.h)
+
+ # rapidyaml includes fast_float as a submodule, saves us pulling it in directly.
+ # Normally, we'd just pull in the cmake project, and link to it, but... it seems to enable
+@@ -188,7 +185,6 @@ add_subdirectory(3rdparty/jpgd EXCLUDE_FROM_ALL)
+ add_subdirectory(3rdparty/simpleini EXCLUDE_FROM_ALL)
+ add_subdirectory(3rdparty/imgui EXCLUDE_FROM_ALL)
+ add_subdirectory(3rdparty/cpuinfo EXCLUDE_FROM_ALL)
+-add_subdirectory(3rdparty/zydis EXCLUDE_FROM_ALL)
+
+ if(USE_OPENGL)
+ add_subdirectory(3rdparty/glad EXCLUDE_FROM_ALL)
+diff --git a/pcsx2/CMakeLists.txt b/pcsx2/CMakeLists.txt
+index ebca2ebf9..bb1e54ab9 100644
+--- a/pcsx2/CMakeLists.txt
++++ b/pcsx2/CMakeLists.txt
+@@ -1221,12 +1221,10 @@ target_link_libraries(PCSX2_FLAGS INTERFACE
+ imgui
+ fmt::fmt
+ ryml
+- chdr-static
++ PkgConfig::LIBCHDR
+ libzip::zip
+ cpuinfo
+- zydis
+ ZLIB::ZLIB
+- PkgConfig::SOUNDTOUCH
+ PNG::PNG
+ LibLZMA::LibLZMA
+ Zstd::Zstd