summarylogtreecommitdiffstats
path: root/use-system-libs.patch
diff options
context:
space:
mode:
authorAlexandre Bouvier2023-04-10 23:43:02 +0200
committerAlexandre Bouvier2023-04-10 23:43:02 +0200
commitd4c35481ed0ae4f5bfae9e2ae0531ce74cef32e7 (patch)
tree13e9e4a5a53798741723e14d8d0a9e5433302f4b /use-system-libs.patch
parente83c4acca844caaadd9db1b811191d26ff0e6c8c (diff)
downloadaur-d4c35481ed0ae4f5bfae9e2ae0531ce74cef32e7.tar.gz
update to r16920.6ac2ffda5
Diffstat (limited to 'use-system-libs.patch')
-rw-r--r--use-system-libs.patch12
1 files changed, 6 insertions, 6 deletions
diff --git a/use-system-libs.patch b/use-system-libs.patch
index 340d0e7b4699..28bc7645676d 100644
--- a/use-system-libs.patch
+++ b/use-system-libs.patch
@@ -1,5 +1,5 @@
diff --git a/cmake/BuildParameters.cmake b/cmake/BuildParameters.cmake
-index 907d23e52..cbed1bfd4 100644
+index fcd341238..6641a0316 100644
--- a/cmake/BuildParameters.cmake
+++ b/cmake/BuildParameters.cmake
@@ -17,14 +17,12 @@ if(LIBRETRO)
@@ -16,15 +16,15 @@ index 907d23e52..cbed1bfd4 100644
-optional_system_library(SDL2)
option(LTO_PCSX2_CORE "Enable LTO/IPO/LTCG on the subset of pcsx2 that benefits most from it but not anything else")
- option(USE_VTUNE "Plug VTUNE to profile GS JIT.")
+
diff --git a/cmake/SearchForStuff.cmake b/cmake/SearchForStuff.cmake
-index 35b207f2e..7184675b6 100644
+index f4d88a186..eb0399dc6 100644
--- a/cmake/SearchForStuff.cmake
+++ b/cmake/SearchForStuff.cmake
@@ -76,7 +76,6 @@ else()
check_lib(SOUNDTOUCH SoundTouch SoundTouch.h PATH_SUFFIXES soundtouch)
- if(NOT QT_BUILD AND NOT APPLE)
+ if(NOT QT_BUILD)
- find_optional_system_library(SDL2 3rdparty/sdl2 2.0.12)
endif()
@@ -56,10 +56,10 @@ index 35b207f2e..7184675b6 100644
if(USE_OPENGL)
add_subdirectory(3rdparty/glad EXCLUDE_FROM_ALL)
diff --git a/pcsx2/CMakeLists.txt b/pcsx2/CMakeLists.txt
-index ebca2ebf9..bb1e54ab9 100644
+index b25010517..2dfba1a5e 100644
--- a/pcsx2/CMakeLists.txt
+++ b/pcsx2/CMakeLists.txt
-@@ -1221,12 +1221,10 @@ target_link_libraries(PCSX2_FLAGS INTERFACE
+@@ -1165,12 +1165,10 @@ target_link_libraries(PCSX2_FLAGS INTERFACE
imgui
fmt::fmt
ryml