summarylogtreecommitdiffstats
path: root/use-system-vstsdk.patch
diff options
context:
space:
mode:
authorKenjiTakahashi2017-02-02 04:56:24 +0100
committerKenjiTakahashi2017-02-02 04:56:24 +0100
commit0b5fb2e23cc56482985c32361145501f32547ce1 (patch)
tree500acfb7a810aa8835cea85c9335e1a823d15ece /use-system-vstsdk.patch
parente8d35f22c9b0fd0665cae6e498bc907cbcac8be2 (diff)
downloadaur-0b5fb2e23cc56482985c32361145501f32547ce1.tar.gz
4.4.4-1: Bumped version
1. Adjusted faust patch for clang 3.9.1. 2. Adjusted vstsdk patch for upstream changes. 3. Using libxcb from [extra] to make sure we have all necessary patches. [Also makes libthread-stubs unneeded.] 4. Fixed X11_keyboard compilation flags.
Diffstat (limited to 'use-system-vstsdk.patch')
-rw-r--r--use-system-vstsdk.patch8
1 files changed, 4 insertions, 4 deletions
diff --git a/use-system-vstsdk.patch b/use-system-vstsdk.patch
index 83f906bdba98..2fe716d09343 100644
--- a/use-system-vstsdk.patch
+++ b/use-system-vstsdk.patch
@@ -5,8 +5,8 @@ diff -aur --no-dereference package.pristine/Makefile.Qt package.new/Makefile.Qt
FLAGOPTS = $(DEFINES) -DGUIISQT -DUSE_GFX_OP_QUEUE -DFULL_VERSION=$(FULL_VERSION) -DIS_LITTLE_ENDIAN=1 -DUSE_OPENGL=1 $(VISUAL) $(REQTYPE_TYPE) $(MENU_TYPE)
--COMMONOPT = -c $(RADIUM_BFD_CFLAGS) `cat buildtype.opt` -I$(GCDIR)/include -I$(P) -I$(PYPATH) `cat flagopts.opt` $(MIDIINC) $(OS_OPTS) $(VST_OPTS) -I${HOME}/boost_1_61_0 -I${HOME}/SDKs/vstsdk2.4 -Wextra -Wno-unused-parameter -Wno-missing-field-initializers -fno-omit-frame-pointer
-+COMMONOPT = -c $(RADIUM_BFD_CFLAGS) `cat buildtype.opt` -I$(GCDIR)/include -I$(P) -I$(PYPATH) `cat flagopts.opt` $(MIDIINC) $(OS_OPTS) $(VST_OPTS) -I${HOME}/boost_1_61_0 -I/usr/include/vst36 -Wextra -Wno-unused-parameter -Wno-missing-field-initializers -fno-omit-frame-pointer
+-COMMONOPT = -c $(RADIUM_BFD_CFLAGS) `cat buildtype.opt` -I$(GCDIR)/include -I$(P) -I$(PYPATH) `cat flagopts.opt` $(MIDIINC) $(OS_OPTS) $(VST_OPTS) -I${HOME}/boost_1_62_0 -I ~/SDKs/VST3\ SDK -Wextra -Wno-unused-parameter -Wno-missing-field-initializers -fno-omit-frame-pointer -Wno-unknown-pragmas
++COMMONOPT = -c $(RADIUM_BFD_CFLAGS) `cat buildtype.opt` -I$(GCDIR)/include -I$(P) -I$(PYPATH) `cat flagopts.opt` $(MIDIINC) $(OS_OPTS) $(VST_OPTS) -I${HOME}/boost_1_62_0 -I/usr/include/vst36 -Wextra -Wno-unused-parameter -Wno-missing-field-initializers -fno-omit-frame-pointer -Wno-unknown-pragmas
ifeq ($(RADIUM_QT_VERSION),5)
COMMONOPT += -DUSE_QT5
@@ -17,8 +17,8 @@ diff -aur --no-dereference package.pristine/check_dependencies.sh package.new/ch
exit 5
fi
--if [ ! -f ~/SDKs/vstsdk2.4/pluginterfaces/vst2.x/aeffect.h ] ; then
-- echo 'Steinberg VST headers not found. (Missing "~/SDKs/vstsdk2.4/pluginterfaces/vst2.x/aeffect.h")'
+-if [[ ! -f ~/SDKs/vstsdk2.4/pluginterfaces/vst2.x/aeffect.h && ! -f ~/SDKs/"VST3 SDK"/pluginterfaces/vst2.x/aeffect.h ]] ; then
+- echo 'Steinberg VST headers not found. (Missing "~/SDKs/vstsdk2.4/pluginterfaces/vst2.x/aeffect.h or "~/SDKs/VST3 SDK/pluginterfaces/vst2.x/aeffect.h")'
+if [ ! -f /usr/include/vst36/pluginterfaces/vst2.x/aeffect.h ] ; then
+ echo 'Steinberg VST headers not found. (Missing "/usr/include/vst36/pluginterfaces/vst2.x/aeffect.h")'
echo 'You should find these files in the "VST Audio Plug-Ins SDK" from http://www.steinberg.net/en/company/developers.html'