summarylogtreecommitdiffstats
path: root/use-system-vstsdk.patch
diff options
context:
space:
mode:
authorTeteros2018-09-16 17:31:58 +0100
committerTeteros2018-09-16 17:31:58 +0100
commit24b1cad10a066382e5091c1f7cc7e07a474636b5 (patch)
tree5a6c37bdcf71e1e79f8974aa070053368f60f093 /use-system-vstsdk.patch
parentdd5897f00ca0f4f6af23a45774bda733d6212773 (diff)
downloadaur-24b1cad10a066382e5091c1f7cc7e07a474636b5.tar.gz
5.9.0-1: New PKGBUILD using upstream install.sh
See discussion on Radium's issue tracker for details https://github.com/kmatheussen/radium/issues/1153
Diffstat (limited to 'use-system-vstsdk.patch')
-rw-r--r--use-system-vstsdk.patch33
1 files changed, 17 insertions, 16 deletions
diff --git a/use-system-vstsdk.patch b/use-system-vstsdk.patch
index 727297f87d08..2a55aa1b988d 100644
--- a/use-system-vstsdk.patch
+++ b/use-system-vstsdk.patch
@@ -1,32 +1,33 @@
-diff -aur --no-dereference radium-5.8.6.pristine/check_dependencies.sh radium-5.8.6.new/check_dependencies.sh
---- radium-5.8.6.pristine/check_dependencies.sh 2018-09-08 10:49:44.000000000 +0100
-+++ radium-5.8.6.new/check_dependencies.sh 2018-09-08 12:56:23.433056983 +0100
-@@ -181,8 +181,8 @@
+diff -aur --no-dereference radium-5.8.9.pristine/check_dependencies.sh radium-5.8.9.new/check_dependencies.sh
+--- radium-5.8.9.pristine/check_dependencies.sh 2018-09-12 17:40:04.000000000 +0100
++++ radium-5.8.9.new/check_dependencies.sh 2018-09-15 08:13:53.091842255 +0100
+@@ -181,11 +181,6 @@
exit 5
fi
-if [[ ! -f ~/SDKs/vstsdk2.4/pluginterfaces/vst2.x/aeffect.h && ! -f ~/SDKs/"VST3 SDK"/pluginterfaces/vst2.x/aeffect.h && ! -f ~/SDKs/VST_SDK/VST2_SDK/pluginterfaces/vst2.x/aeffect.h ]] ; then
- echo 'Steinberg VST headers not found. (Missing "~/SDKs/vstsdk2.4/pluginterfaces/vst2.x/aeffect.h or "~/SDKs/VST3 SDK/pluginterfaces/vst2.x/aeffect.h" or "~/SDKs/VST_SDK/VST2_SDK/pluginterfaces/vst2.x/aeffect.h")'
-+if [[ ! -f /usr/include/vst36/pluginterfaces/vst2.x/aeffect.h && ! -f ~/SDKs/vstsdk2.4/pluginterfaces/vst2.x/aeffect.h && ! -f ~/SDKs/"VST3 SDK"/pluginterfaces/vst2.x/aeffect.h && ! -f ~/SDKs/VST_SDK/VST2_SDK/pluginterfaces/vst2.x/aeffect.h ]] ; then
-+ echo 'Steinberg VST headers not found. (Missing "/usr/include/vst36/pluginterfaces/vst2.x/aeffect.h" or "~/SDKs/vstsdk2.4/pluginterfaces/vst2.x/aeffect.h or "~/SDKs/VST3 SDK/pluginterfaces/vst2.x/aeffect.h" or "~/SDKs/VST_SDK/VST2_SDK/pluginterfaces/vst2.x/aeffect.h")'
- echo 'You should find these files in the "VST Audio Plug-Ins SDK" from http://www.steinberg.net/en/company/developers.html . Unless Steinberg have changed the directory structure again, it should enough to unzip the file into your ~/SDKs directory.'
- exit 5
- fi
-diff -aur --no-dereference radium-5.8.6.pristine/Makefile.Qt radium-5.8.6.new/Makefile.Qt
---- radium-5.8.6.pristine/Makefile.Qt 2018-09-08 10:49:44.000000000 +0100
-+++ radium-5.8.6.new/Makefile.Qt 2018-09-08 12:57:44.603057081 +0100
+- echo 'You should find these files in the "VST Audio Plug-Ins SDK" from http://www.steinberg.net/en/company/developers.html . Unless Steinberg have changed the directory structure again, it should enough to unzip the file into your ~/SDKs directory.'
+- exit 5
+-fi
+
+
+ if [[ $4 == "test_build" ]] ; then
+diff -aur --no-dereference radium-5.8.9.pristine/Makefile.Qt radium-5.8.9.new/Makefile.Qt
+--- radium-5.8.9.pristine/Makefile.Qt 2018-09-12 17:40:04.000000000 +0100
++++ radium-5.8.9.new/Makefile.Qt 2018-09-15 08:13:53.091842255 +0100
@@ -235,7 +235,7 @@
FLAGOPTS = $(DEFINES) -DGUIISQT -DUSE_GFX_OP_QUEUE -DFULL_VERSION=$(FULL_VERSION) -DIS_LITTLE_ENDIAN=1 -DUSE_OPENGL=1 $(VISUAL) $(REQTYPE_TYPE) $(MENU_TYPE)
-COMMONOPT = -c $(RADIUM_BFD_CFLAGS) `cat buildtype.opt` -I$(GCDIR)/include -I$(P) -I$(PYPATH) `cat flagopts.opt` $(MIDIINC) $(OS_OPTS) $(VST_OPTS) -I${HOME}/boost_1_63_0 -I${HOME}/boost_1_67_0 -I ~/SDKs/VST_SDK/VST2_SDK/ -I ~/SDKs/VST3\ SDK -I ~/SDKs/vstsdk2.4/ -Wextra -Wno-unused-parameter -Wno-missing-field-initializers -Wno-unknown-pragmas -fno-strict-aliasing -Wmissing-field-initializers
-+COMMONOPT = -c $(RADIUM_BFD_CFLAGS) `cat buildtype.opt` -I$(GCDIR)/include -I$(P) -I$(PYPATH) `cat flagopts.opt` $(MIDIINC) $(OS_OPTS) $(VST_OPTS) -I${HOME}/boost_1_63_0 -I /usr/include/vst36 -I${HOME}/boost_1_67_0 -I ~/SDKs/VST_SDK/VST2_SDK/ -I ~/SDKs/VST3\ SDK -I ~/SDKs/vstsdk2.4/ -Wextra -Wno-unused-parameter -Wno-missing-field-initializers -Wno-unknown-pragmas -fno-strict-aliasing -Wmissing-field-initializers
++COMMONOPT = -c $(RADIUM_BFD_CFLAGS) `cat buildtype.opt` -I$(GCDIR)/include -I$(P) -I$(PYPATH) `cat flagopts.opt` $(MIDIINC) $(OS_OPTS) $(VST_OPTS) -I${HOME}/boost_1_63_0 -I${HOME}/boost_1_67_0 -I /usr/include/vst36 -I ~/SDKs/VST_SDK/VST2_SDK/ -I ~/SDKs/VST3\ SDK -I ~/SDKs/vstsdk2.4/ -Wextra -Wno-unused-parameter -Wno-missing-field-initializers -Wno-unknown-pragmas -fno-strict-aliasing -Wmissing-field-initializers
#-Wstrict-overflow=4 -Wsuggest-attribute=format -Wstringop-overflow=4
#-Wsuggest-final-types -Wsuggest-final-methods
-diff -aur --no-dereference radium-5.8.6.pristine/pluginhost/Builds/Linux/Makefile radium-5.8.6.new/pluginhost/Builds/Linux/Makefile
---- radium-5.8.6.pristine/pluginhost/Builds/Linux/Makefile 2018-09-08 10:49:44.000000000 +0100
-+++ radium-5.8.6.new/pluginhost/Builds/Linux/Makefile 2018-09-08 12:56:23.433056983 +0100
+diff -aur --no-dereference radium-5.8.9.pristine/pluginhost/Builds/Linux/Makefile radium-5.8.9.new/pluginhost/Builds/Linux/Makefile
+--- radium-5.8.9.pristine/pluginhost/Builds/Linux/Makefile 2018-09-12 17:40:04.000000000 +0100
++++ radium-5.8.9.new/pluginhost/Builds/Linux/Makefile 2018-09-15 08:13:53.091842255 +0100
@@ -8,7 +8,7 @@
CONFIG=Debug
endif