summarylogtreecommitdiffstats
path: root/use-usr-libs.patch
diff options
context:
space:
mode:
authorJean-Gabriel Young2019-06-23 16:35:57 -0400
committerJean-Gabriel Young2019-06-23 16:35:57 -0400
commit10daff16516e29fb70a21e07447b4a4157f621cf (patch)
tree3e6363726b934b73d29c5cd026f0a0548cfe095c /use-usr-libs.patch
parent03216200dfc0d122aeccb19610b5f7da546cf6ee (diff)
downloadaur-10daff16516e29fb70a21e07447b4a4157f621cf.tar.gz
Modified PKGBUILD to use installed C++ libraries instead of libraries shipped with pystan
Diffstat (limited to 'use-usr-libs.patch')
-rw-r--r--use-usr-libs.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/use-usr-libs.patch b/use-usr-libs.patch
new file mode 100644
index 000000000000..fe920f187234
--- /dev/null
+++ b/use-usr-libs.patch
@@ -0,0 +1,18 @@
+diff --unified --recursive --text pystan-2.19.0.0/setup.py pystan-2.19.0.0/setup.py
+--- pystan-2.19.0.0/setup.py 2019-04-02 16:12:04.000000000 -0400
++++ pystan-2.19.0.0/setup.py 2019-06-23 15:55:25.641273923 -0400
+@@ -100,9 +100,11 @@
+
+ stan_include_dirs = ['pystan/stan/src',
+ 'pystan/stan/lib/stan_math/',
+- 'pystan/stan/lib/stan_math/lib/eigen_3.3.3',
+- 'pystan/stan/lib/stan_math/lib/boost_1.69.0',
+- 'pystan/stan/lib/stan_math/lib/sundials_4.1.0/include']
++ '/usr/include/eigen3/',
++ '/usr/include/boost/',
++ '/usr/include/sundials/',
++ '/usr/include/cvode/',
++ '/usr/include/cvodes/']
+ stan_macros = [
+ ('BOOST_DISABLE_ASSERTS', None),
+ ('BOOST_NO_DECLTYPE', None),