summarylogtreecommitdiffstats
path: root/va-11-hall-a-gog
diff options
context:
space:
mode:
authordplusplus2022-03-03 02:15:26 -0800
committerdplusplus2022-03-03 02:15:26 -0800
commit9184409f4fe272200ddbd606daf7ae672b6af3fc (patch)
tree5aac13bedb0c8982da3783f191c17de26778096d /va-11-hall-a-gog
downloadaur-9184409f4fe272200ddbd606daf7ae672b6af3fc.tar.gz
Working PKGBUILD and other files for VA-11 Hall-A (GOG version)
Diffstat (limited to 'va-11-hall-a-gog')
-rw-r--r--va-11-hall-a-gog26
1 files changed, 26 insertions, 0 deletions
diff --git a/va-11-hall-a-gog b/va-11-hall-a-gog
new file mode 100644
index 000000000000..649d5c4a7b0a
--- /dev/null
+++ b/va-11-hall-a-gog
@@ -0,0 +1,26 @@
+#!/bin/sh
+
+pkgname="va-11-hall-a-gog"
+pkgdir="/opt/${pkgname}"
+run="${pkgdir}/start.sh"
+run_firejail="firejail --profile=/etc/firejail/${pkgname}.profile ${run}"
+
+
+if hash firejail; then
+ echo "Firejail detected; attempting to enforce a sandbox..."
+ if [[ -f "${XDG_CONFIG_HOME}/firejail/${pkgname}.profile" ]]; then
+ echo "Firejail profile for ${pkgname} found in ${XDG_CONFIG_HOME}/firejail/"
+ echo "Enforcing a sandbox!"
+ eval "${run_firejail}"
+ elif [[ -f "/etc/firejail/${pkgname}.profile" ]]; then
+ echo "Firejail profile for ${pkgname} found in /etc/firejail/"
+ echo "Enforcing a sandbox!"
+ eval "${run_firejail}"
+ else
+ echo "No Firejail profile detected!"
+ echo "Skipping Firejail sandbox..."
+ eval "${run}"
+ fi
+else
+ ${run}
+fi