aboutsummarylogtreecommitdiffstats
path: root/vertexbuffer-crash-fix.patch
diff options
context:
space:
mode:
authorlectrode2024-06-30 15:12:10 -0600
committerlectrode2024-06-30 15:12:10 -0600
commit9c6e13fc85da348a5b245a29f5900f2f55fcc006 (patch)
treeb70ba26c58d2d3c89931611541673b4e1b1b3592 /vertexbuffer-crash-fix.patch
parent53a8f309d97e9cb119b6c669b36dd00de1f52c03 (diff)
downloadaur-9c6e13fc85da348a5b245a29f5900f2f55fcc006.tar.gz
v0.9.14.2-5.1 vertexbuffer crash fix
* add patch to fix crash when using expo with wobbly windows enabled Thanks to leso-kn for the patch, and PhotonX for reporting. https://gitlab.alpinelinux.org/alpine/aports/-/merge_requests/66215/diffs?commit_id=d0a0b3738fe16858024addcefa8fc917a5aa6fe0
Diffstat (limited to 'vertexbuffer-crash-fix.patch')
-rw-r--r--vertexbuffer-crash-fix.patch73
1 files changed, 73 insertions, 0 deletions
diff --git a/vertexbuffer-crash-fix.patch b/vertexbuffer-crash-fix.patch
new file mode 100644
index 000000000000..c55fd5098c5d
--- /dev/null
+++ b/vertexbuffer-crash-fix.patch
@@ -0,0 +1,73 @@
+diff --git a/plugins/opengl/CMakeLists.txt b/plugins/opengl/CMakeLists.txt
+index 63db12b..2fc6046 100644
+--- a/plugins/opengl/CMakeLists.txt
++++ b/plugins/opengl/CMakeLists.txt
+@@ -21,7 +21,7 @@ include_directories (src/glxtfpbind/include)
+ else (USE_GLES)
+ find_package (OpenGL)
+ if (OPENGL_FOUND)
+- compiz_plugin(opengl PLUGINDEPS composite LIBRARIES ${OPENGL_opengl_LIBRARY} ${OPENGL_glx_LIBRARY} ${INTERNAL_LIBRARIES} dl INCDIRS ${OPENGL_INCLUDE_DIR})
++ compiz_plugin(opengl PLUGINDEPS composite LIBRARIES ${OPENGL_LIBRARIES} ${INTERNAL_LIBRARIES} dl INCDIRS ${OPENGL_INCLUDE_DIR})
+ endif (OPENGL_FOUND)
+ endif (USE_GLES)
+
+diff --git a/cmake/plugin_extensions/CompizOpenGLFixups.cmake b/cmake/plugin_extensions/CompizOpenGLFixups.cmake
+index 8691371..f230ceb 100644
+--- a/cmake/plugin_extensions/CompizOpenGLFixups.cmake
++++ b/cmake/plugin_extensions/CompizOpenGLFixups.cmake
+@@ -4,7 +4,7 @@ if (${COMPIZ_CURRENT_PLUGIN} STREQUAL "opengl")
+ if (USE_GLES)
+ set (PKGCONFIG_LIBS "${OPENGL_egl_LIBRARY} -lGLESv2")
+ else (USE_GLES)
+- set (PKGCONFIG_LIBS "${OPENGL_opengl_LIBRARY} ${OPENGL_glx_LIBRARY}")
++ set (PKGCONFIG_LIBS "${OPENGL_LIBRARIES}")
+ endif (USE_GLES)
+ endif (${COMPIZ_CURRENT_PLUGIN} STREQUAL "opengl")
+
+diff --git a/plugins/opengl/compiz-opengl.pc.in b/plugins/opengl/compiz-opengl.pc.in
+index d8b0b79..12c55c7 100644
+--- a/plugins/opengl/compiz-opengl.pc.in
++++ b/plugins/opengl/compiz-opengl.pc.in
+@@ -8,5 +8,5 @@ Description: Opengl compositing plugin for compiz
+ Version: @VERSION@
+
+ Requires: compiz compiz-composite
+-Libs: @PKGCONFIG_LIBS@ -L${libdir} -lopengl
++Libs: -lGL -L${libdir} -lopengl
+ Cflags: @COMPIZ_CFLAGS@ -I${includedir}/compiz
+\ No newline at end of file
+diff --git a/plugins/opengl/src/screen.cpp b/plugins/opengl/src/screen.cpp
+index fcf19ca..39bf966 100644
+--- a/plugins/opengl/src/screen.cpp
++++ b/plugins/opengl/src/screen.cpp
+@@ -40,6 +40,7 @@
+
+ #include <dlfcn.h>
+ #include <math.h>
++#include <GL/glx.h>
+
+ using namespace boost::placeholders;
+
+@@ -1354,8 +1355,7 @@ GLScreen::GLScreen (CompScreen *s) :
+ GL::bufferAge = true;
+ }
+
+- priv->getProcAddress = (GL::GLXGetProcAddressProc)
+- getProcAddress ("glXGetProcAddressARB");
++ priv->getProcAddress = &glXGetProcAddressARB;
+ GL::bindTexImage = (GL::GLXBindTexImageProc)
+ getProcAddress ("glXBindTexImageEXT");
+ GL::releaseTexImage = (GL::GLXReleaseTexImageProc)
+diff --git a/plugins/opengl/src/vertexbuffer.cpp b/plugins/opengl/src/vertexbuffer.cpp
+index b102016..4e314c2 100644
+--- a/plugins/opengl/src/vertexbuffer.cpp
++++ b/plugins/opengl/src/vertexbuffer.cpp
+@@ -164,7 +164,7 @@ void GLVertexBuffer::addVertices (GLuint nVertices, const GLfloat *vertices)
+
+ GLfloat *GLVertexBuffer::getVertices() const
+ {
+- return &priv->vertexData[0];
++ return priv->vertexData.data();
+ }
+
+ int GLVertexBuffer::getVertexStride() const