summarylogtreecommitdiffstats
path: root/vmmon.patch
diff options
context:
space:
mode:
authorJean-Marc Lenoir2018-02-03 13:22:45 +0100
committerJean-Marc Lenoir2018-02-03 13:22:45 +0100
commitb30b0899395c3977857900ab89b47d3c2ee175e4 (patch)
treea24a3715368f36d2576ae4eca9928080c3dbc7ee /vmmon.patch
parentfe7e26e5a1757f64867a1fbce456d9f6f07e8bd3 (diff)
downloadaur-b30b0899395c3977857900ab89b47d3c2ee175e4.tar.gz
Cleanup
Diffstat (limited to 'vmmon.patch')
-rw-r--r--vmmon.patch126
1 files changed, 0 insertions, 126 deletions
diff --git a/vmmon.patch b/vmmon.patch
index a8d36efcc07d..d69f3135cb1b 100644
--- a/vmmon.patch
+++ b/vmmon.patch
@@ -14,129 +14,3 @@ index de8162e..6124a71 100644
# Header directory for the running kernel
ifdef LINUXINCLUDE
-diff --git a/vmmon/Makefile.kernel b/vmmon/Makefile.kernel
-index bf805e0..9aac585 100644
---- a/vmmon/Makefile.kernel
-+++ b/vmmon/Makefile.kernel
-@@ -22,7 +22,7 @@ CC_OPTS += -DVMMON -DVMCORE
- INCLUDE := -I$(SRCROOT)/include -I$(SRCROOT)/common -I$(SRCROOT)/linux \
- -I$(SRCROOT)/vmcore
-
--EXTRA_CFLAGS := $(CC_OPTS) $(INCLUDE)
-+EXTRA_CFLAGS := $(CC_OPTS) $(INCLUDE) $(LINUXINCLUDE)
-
- obj-m += $(DRIVER).o
-
-diff --git a/vmmon/include/compat_module.h b/vmmon/include/compat_module.h
-index 2af7372..729aedc 100644
---- a/vmmon/include/compat_module.h
-+++ b/vmmon/include/compat_module.h
-@@ -80,4 +80,13 @@ static const char __module_cat(tag, __LINE__)[] \
- typedef int compat_mod_param_bool;
- #endif
-
-+/*
-+ * Linux kernel >= 4.3.0 does not return anything from misc_deregister
-+ */
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 3, 0)
-+#define compat_misc_deregister(misc) misc_deregister(misc)
-+#else
-+#define compat_misc_deregister(misc) ({misc_deregister(misc);0;})
-+#endif
-+
- #endif /* __COMPAT_MODULE_H__ */
-diff --git a/vmmon/linux/driver.c b/vmmon/linux/driver.c
-index 87cf45b..5390a93 100644
---- a/vmmon/linux/driver.c
-+++ b/vmmon/linux/driver.c
-@@ -109,7 +109,15 @@ static struct vm_operations_struct vmuser_mops = {
- .fault = LinuxDriverFault
- };
-
--static struct file_operations vmuser_fops;
-+static struct file_operations vmuser_fops = {
-+ .owner = THIS_MODULE,
-+ .unlocked_ioctl = LinuxDriver_Ioctl,
-+ .compat_ioctl = LinuxDriver_Ioctl,
-+ .open = LinuxDriver_Open,
-+ .release = LinuxDriver_Close,
-+ .mmap = LinuxDriverMmap
-+};
-+
- static struct timer_list tscTimer;
- static Atomic_uint32 tsckHz;
- static VmTimeStart tsckHzStartTime;
-@@ -293,20 +301,6 @@ init_module(void)
- linuxState.fastClockRate = 0;
- linuxState.swapSize = VMMON_UNKNOWN_SWAP_SIZE;
-
-- /*
-- * Initialize the file_operations structure. Because this code is always
-- * compiled as a module, this is fine to do it here and not in a static
-- * initializer.
-- */
--
-- memset(&vmuser_fops, 0, sizeof vmuser_fops);
-- vmuser_fops.owner = THIS_MODULE;
-- vmuser_fops.unlocked_ioctl = LinuxDriver_Ioctl;
-- vmuser_fops.compat_ioctl = LinuxDriver_Ioctl;
-- vmuser_fops.open = LinuxDriver_Open;
-- vmuser_fops.release = LinuxDriver_Close;
-- vmuser_fops.mmap = LinuxDriverMmap;
--
- #ifdef VMX86_DEVEL
- devel_init_module();
- linuxState.minor = 0;
-@@ -368,7 +362,9 @@ cleanup_module(void)
- #ifdef VMX86_DEVEL
- unregister_chrdev(linuxState.major, linuxState.deviceName);
- #else
-- misc_deregister(&linuxState.misc);
-+ if (compat_misc_deregister(&linuxState.misc)) {
-+ Warning("Module %s: error unregistering\n", linuxState.deviceName);
-+ }
- #endif
-
- Log("Module %s: unloaded\n", linuxState.deviceName);
-@@ -981,7 +977,7 @@ LinuxDriverReadTSC(void *data, // OUT: TSC values
- *-----------------------------------------------------------------------------
- */
-
--__attribute__((always_inline)) static Bool
-+inline __attribute__((always_inline)) static Bool
- LinuxDriverSyncReadTSCs(uint64 *delta) // OUT: TSC max - TSC min
- {
- TSCDelta tscDelta;
-diff --git a/vmmon/linux/hostif.c b/vmmon/linux/hostif.c
-index fd32013..583d6da 100644
---- a/vmmon/linux/hostif.c
-+++ b/vmmon/linux/hostif.c
-@@ -36,6 +36,9 @@
-
- #include <linux/vmalloc.h>
- #include <linux/slab.h>
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 11, 0)
-+#include <linux/sched/signal.h>
-+#endif
-
- #include <linux/preempt.h>
- #include <linux/poll.h>
-@@ -51,6 +54,7 @@
- #include <linux/capability.h>
- #include <linux/kthread.h>
- #include <linux/wait.h>
-+#include <asm/apic.h>
- #include <linux/hrtimer.h>
- #include <linux/signal.h>
- #include <linux/taskstats_kern.h> // For linux/sched/signal.h without version check
-@@ -115,6 +149,10 @@
- */
- #define LOCKED_PAGE_SLACK 10000
-
-+#if LINUX_VERSION_CODE > KERNEL_VERSION(4, 8, 0)
-+#define NR_ANON_PAGES NR_ANON_MAPPED
-+#endif
-+
- static struct {
- Atomic_uint64 uptimeBase;
- VersionedAtomic version;