summarylogtreecommitdiffstats
path: root/vmmon.patch
diff options
context:
space:
mode:
authorJean-Marc Lenoir2023-10-21 15:47:17 +0200
committerJean-Marc Lenoir2023-10-21 15:47:17 +0200
commit22b92ff558f4b59fcb4a5c86fa9fb0120a615d21 (patch)
treee9dcb2a751ab8cfd5b6659e31f20094b66840da7 /vmmon.patch
parent63f28a5a80764053ff4ccf13cc011c979bd6c08f (diff)
downloadaur-22b92ff558f4b59fcb4a5c86fa9fb0120a615d21.tar.gz
Sync with vmware-workstation 17.5.0
Diffstat (limited to 'vmmon.patch')
-rw-r--r--vmmon.patch26
1 files changed, 14 insertions, 12 deletions
diff --git a/vmmon.patch b/vmmon.patch
index 33efbf177acb..c2f4b36d9ffb 100644
--- a/vmmon.patch
+++ b/vmmon.patch
@@ -20,6 +20,20 @@
include $(SRCROOT)/Makefile.kernel
+--- a/vmmon/include/pgtbl.h
++++ b/vmmon/include/pgtbl.h
+@@ -91,7 +91,11 @@
+ } else {
+ pte_t *pte;
+
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(6,5,0)
++ pte = pte_offset_kernel(pmd, addr);
++#else
+ pte = pte_offset_map(pmd, addr);
++#endif
+ if (pte_present(*pte) == 0) {
+ pte_unmap(pte);
+ return INVALID_MPN;
--- a/vmmon/include/vm_basic_defs.h
+++ b/vmmon/include/vm_basic_defs.h
@@ -50,7 +50,10 @@
@@ -298,15 +312,3 @@
/*
* Do not exit thread until we are told to do so.
*/
-Patch taken from https://raw.githubusercontent.com/jeffersonchua/linux-6.5.0/main/patch-17.0.2-6.5.0
---- a/vmmon/include/pgtbl.h
-+++ b/vmmon/include/pgtbl.h
-@@ -91,7 +91,7 @@
- } else {
- pte_t *pte;
-
-- pte = pte_offset_map(pmd, addr);
-+ pte = pte_offset_kernel(pmd, addr);
- if (pte_present(*pte) == 0) {
- pte_unmap(pte);
- return INVALID_MPN;