summarylogtreecommitdiffstats
path: root/vmnet.patch
diff options
context:
space:
mode:
authorJean-Marc Lenoir2019-07-27 13:03:27 +0200
committerJean-Marc Lenoir2019-07-27 13:03:27 +0200
commitecfb8ae56d100762fa9a71339b3869bc048cfda8 (patch)
tree4883408f883fb48ef4a6974cab19c622c0562142 /vmnet.patch
parent8301a140f54119b05d9cd80b24099fa58e41f4be (diff)
downloadaur-ecfb8ae56d100762fa9a71339b3869bc048cfda8.tar.gz
Compatibility with Linux 5.3-rc1
Diffstat (limited to 'vmnet.patch')
-rw-r--r--vmnet.patch29
1 files changed, 27 insertions, 2 deletions
diff --git a/vmnet.patch b/vmnet.patch
index d2c620705ca3..5dd6491341ca 100644
--- a/vmnet.patch
+++ b/vmnet.patch
@@ -1,5 +1,3 @@
-diff --git a/vmnet/Makefile b/vmnet/Makefile
-index 459846e..cd29652 100644
--- a/vmnet/Makefile
+++ b/vmnet/Makefile
@@ -43,7 +43,11 @@ INCLUDE += -I$(SRCROOT)/shared
@@ -14,3 +12,30 @@ index 459846e..cd29652 100644
# Header directory for the running kernel
ifdef LINUXINCLUDE
+From 8ba37a5023f939ba8d2e0d91b916ff442b1c18dd Mon Sep 17 00:00:00 2001
+From: Michal Kubecek <mkubecek@suse.cz>
+Date: Mon, 31 Dec 2018 00:05:42 +0100
+Subject: [PATCH] modules: replace SUBDIRS with M
+
+Since commit 0126be38d988 ("kbuild: announce removal of SUBDIRS if used")
+in v5.0-rc1, using SUBDIRS when building out of tree modules produces
+a deprecation warning. As M used to work since pretty much ever, use it
+unconditionally.
+---
+ vmmon-only/Makefile | 2 +-
+ vmnet-only/Makefile | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/vmnet-only/Makefile b/vmnet-only/Makefile
+index caab6b9..c2fc51f 100644
+--- a/vmnet-only/Makefile
++++ b/vmnet-only/Makefile
+@@ -111,7 +111,7 @@ prebuild:: ;
+ postbuild:: ;
+
+ $(DRIVER_KO): prebuild
+- $(MAKE) -C $(BUILD_DIR) SUBDIRS=$$PWD SRCROOT=$$PWD/$(SRCROOT) \
++ $(MAKE) -C $(BUILD_DIR) M=$$PWD SRCROOT=$$PWD/$(SRCROOT) \
+ MODULEBUILDDIR=$(MODULEBUILDDIR) modules
+ $(MAKE) -C $$PWD SRCROOT=$$PWD/$(SRCROOT) \
+ MODULEBUILDDIR=$(MODULEBUILDDIR) postbuild