summarylogtreecommitdiffstats
path: root/wev-git.patch
diff options
context:
space:
mode:
authorStephen Gregoratto2020-03-30 13:45:18 +1100
committerStephen Gregoratto2020-03-30 13:45:18 +1100
commit6a7c5fab20c7b040792a45d0d04fbcce069b1836 (patch)
treec02edca61c59c1b74f1d74be57a780a13fc2df77 /wev-git.patch
parentb3808f8c429668833c8f4b931ff5cc9a87aa7bc4 (diff)
downloadaur-6a7c5fab20c7b040792a45d0d04fbcce069b1836.tar.gz
Patch makefile to use (C|CPP|LD)FLAGS
Diffstat (limited to 'wev-git.patch')
-rw-r--r--wev-git.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/wev-git.patch b/wev-git.patch
new file mode 100644
index 000000000000..35d583eebabf
--- /dev/null
+++ b/wev-git.patch
@@ -0,0 +1,16 @@
+diff -ura wev.old/Makefile wev.new/Makefile
+--- wev.old/Makefile 2020-03-30 13:38:48.947716009 +1100
++++ wev.new/Makefile 2020-03-30 13:40:04.044187743 +1100
+@@ -14,10 +14,10 @@
+ $(WAYLAND_PROTOCOLS)/stable/xdg-shell/xdg-shell.xml $@
+
+ wev: wev.c shm.c xdg-shell-protocol.h xdg-shell-protocol.c
+- $(CC) $(CFLAGS) \
++ $(CC) $(CPPFLAGS) $(CFLAGS) \
+ -g -std=c11 -I. \
+ -o wev wev.c shm.c xdg-shell-protocol.c \
+- $(LIBS) -lrt
++ $(LIBS) -lrt $(LDFLAGS)
+
+ wev.1: wev.1.scd
+ $(SCDOC) < wev.1.scd > wev.1