summarylogtreecommitdiffstats
path: root/xdg_fix.patch
diff options
context:
space:
mode:
authorTed Alff2015-12-28 08:57:53 -0500
committerTed Alff2015-12-28 08:57:53 -0500
commit1a687bc3c1562c39415b2da541c2651d4b08c713 (patch)
treed614354679e99fa5b9b7a4d3cdf78554797c9a47 /xdg_fix.patch
parent3511c1b93f43f388fa31ec3cd4283d2b606500f3 (diff)
downloadaur-1a687bc3c1562c39415b2da541c2651d4b08c713.tar.gz
Added xdg patch per melkhatt's comment. Updated PKGBUILD to current VCS methods.
Diffstat (limited to 'xdg_fix.patch')
-rw-r--r--xdg_fix.patch61
1 files changed, 61 insertions, 0 deletions
diff --git a/xdg_fix.patch b/xdg_fix.patch
new file mode 100644
index 000000000000..64449efcb51a
--- /dev/null
+++ b/xdg_fix.patch
@@ -0,0 +1,61 @@
+diff -Naur ./cardapio.old/src/Cardapio.py ./cardapio/src/Cardapio.py
+--- ./cardapio.old/src/Cardapio.py 2015-12-27 23:12:03.443879297 -0500
++++ ./cardapio/src/Cardapio.py 2015-12-27 23:12:29.254221586 -0500
+@@ -41,6 +41,7 @@
+ import gio
+ import glib
+ import json
++ import xdg
+
+ import urllib2
+ import gettext
+@@ -53,6 +54,7 @@
+
+ from time import time
+ from xdg import DesktopEntry
++ from xdg import BaseDirectory
+ from pango import ELLIPSIZE_END
+ from threading import Lock, Thread
+ from locale import setlocale, LC_ALL
+@@ -453,7 +455,7 @@
+ self._plugin_database['pinned'] = {'class' : plugin_class, 'instances' : []}
+
+ plugin_dirs = [
+- os.path.join(DesktopEntry.xdg_config_home, 'Cardapio', 'plugins'),
++ os.path.join(BaseDirectory.xdg_config_home, 'Cardapio', 'plugins'),
+ os.path.join(self.cardapio_path, 'plugins'),
+ ]
+
+@@ -631,7 +633,7 @@
+ ~/.cache/Cardapio)
+ """
+
+- self._config_folder_path = os.path.join(DesktopEntry.xdg_config_home, 'Cardapio')
++ self._config_folder_path = os.path.join(BaseDirectory.xdg_config_home, 'Cardapio')
+
+ if not os.path.exists(self._config_folder_path):
+ os.mkdir(self._config_folder_path)
+@@ -640,7 +642,7 @@
+ fatal_error('Error creating config folder!', 'Cannot create folder "%s" because a file with that name already exists!' % self._config_folder_path)
+ self._quit()
+
+- self._cache_folder_path = os.path.join(DesktopEntry.xdg_cache_home, 'Cardapio')
++ self._cache_folder_path = os.path.join(BaseDirectory.xdg_cache_home, 'Cardapio')
+
+ if not os.path.exists(self._cache_folder_path):
+ os.mkdir(self._cache_folder_path)
+@@ -1931,7 +1933,7 @@
+
+ self._add_app_button(_('Home'), 'user-home', section, 'xdg', self._home_folder_path, _('Open your personal folder'), self._app_list)
+
+- xdg_folders_file_path = os.path.join(DesktopEntry.xdg_config_home, 'user-dirs.dirs')
++ xdg_folders_file_path = os.path.join(BaseDirectory.xdg_config_home, 'user-dirs.dirs') #***
+ xdg_folders_file = file(xdg_folders_file_path, 'r')
+ # TODO: xdg_folders_file = codecs.open(xdg_folders_file_path, mode='r', encoding='utf-8')
+
+@@ -3303,5 +3305,3 @@
+ __builtin__.get_output = get_output
+ __builtin__.fatal_error = fatal_error
+ __builtin__.which = which
+-
+-