summarylogtreecommitdiffstats
path: root/.SRCINFO
diff options
context:
space:
mode:
Diffstat (limited to '.SRCINFO')
-rw-r--r--.SRCINFO121
1 files changed, 62 insertions, 59 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 23c060e0a86..27a3d02588b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,119 +1,122 @@
pkgbase = freeipa
pkgdesc = The Identity, Policy and Audit system
- pkgver = 4.4.3
+ pkgver = 4.5.3
pkgrel = 1
url = http://www.freeipa.org/
arch = i686
arch = x86_64
license = GPL3
- makedepends = nspr
- makedepends = nss
- makedepends = openssl
makedepends = openldap
- makedepends = krb5>=1.13
- makedepends = libutil-linux
- makedepends = curl>7.21.7
+ makedepends = krb5>=1.15.1
makedepends = xmlrpc-c>=1.27.4
makedepends = popt
+ makedepends = gettext
makedepends = python
+ makedepends = python-setuptools
makedepends = python2
- makedepends = python2-ldap
makedepends = python2-setuptools
+ makedepends = nspr
+ makedepends = nss
+ makedepends = openssl
+ makedepends = ding-libs
+ makedepends = libsasl
+ makedepends = python2-ldap
makedepends = python2-nss
- makedepends = python2-cryptography>=0.9
- makedepends = python2-netaddr
- makedepends = python2-gssapi>=1.1.2
- makedepends = python2-memcached
- makedepends = sssd>=1.14.0
- makedepends = python2-lxml
- makedepends = python2-pyasn1>=0.0.9a
- makedepends = python2-qrcode
- makedepends = python2-dnspython>=1.11.1
- makedepends = systemd
- makedepends = libunistring
- makedepends = python2-yubico>=1.2.3
+ makedepends = python2-netaddr>=0.7.16
+ makedepends = python2-pyasn1
+ makedepends = python2-pyasn1-modules
+ makedepends = python2-dnspython
makedepends = python2-six
- makedepends = ding-libs>=0.5.0
- makedepends = python2-dbus
- makedepends = python2-netifaces
- source = http://freeipa.org/downloads/src/freeipa-4.4.3.tar.gz
- source = 0001-platform-add-Arch-Linux-platform.patch
- source = 0002-dogtag-vault-do-not-import-pki-in-makeapi.patch
- source = 0003-client-install-do-not-assume-etc-krb5.conf.d-exists.patch
- sha256sums = 7ab844e16ba23dff9c71d47f59f105a8b2fdb6c407a56326c32528e8e7bb0773
- sha256sums = 73bff9f3677b98c09ff45dd8e2aae7080e0f93218956b978d07346005dab7b6b
- sha256sums = e797910b18f7ed3063a9a454b261960fda2ab133f79ee070bee16e4745489d03
- sha256sums = bc095e230652a8b421bfd1adb546aa4e720bfe8d15f6a9d6872eccac79b3dcbc
+ makedepends = sssd>=1.13.0
+ makedepends = python2-cffi
+ makedepends = python-jinja
+ makedepends = python-pyasn1-modules
+ makedepends = python2-jinja
+ options = emptydirs
+ source = https://releases.pagure.org/freeipa/freeipa-4.5.3.tar.gz
+ source = 0001-install-do-not-assume-etc-krb5.conf.d-exists.patch
+ source = 0002-platform-add-Arch-Linux-platform.patch
+ source = freeipa-client-update-sshd_config
+ source = freeipa-client-update-sshd_config.hook
+ sha256sums = 94c18793cd4f0b008879afabb69ac52f2d9abad71d8ff3c89260ab5af116b81b
+ sha256sums = ffdd4de12728fca3732e0782352a046d6317508c68eca0cc048c80cdb9cc4b3e
+ sha256sums = f30985cdc09070da6c935bc8e3b1f0d870f91766bf6ecdef41815386beccb369
+ sha256sums = 9fbac49fa4bc23afe0c4d575ea2795f1da435399289dbd04c5a3ac47580e2a0d
+ sha256sums = 1e73f394d276357dcd578df7a349b1f381c9edc7b1c053ecf65f7a9255c0490d
pkgname = python-ipalib
pkgdesc = Python libraries used by IPA
arch = any
- depends = freeipa-common=4.4.3-1
- depends = python-gssapi>=1.1.2
+ depends = freeipa-common=4.5.3-1
+ depends = python-gssapi>=1.2.0
depends = gnupg
depends = keyutils
depends = python-nss>=0.16
- depends = python-cryptography>=0.9
- depends = python-lxml
- depends = python-netaddr
+ depends = python-cryptography>=1.4
+ depends = python-netaddr>=0.7.16
depends = sssd
depends = python-qrcode>=5.0.0
depends = python-pyasn1
+ depends = python-pyasn1-modules
depends = python-dateutil
depends = python-yubico>=1.2.3
depends = python-dbus
depends = python-setuptools
depends = python-six
depends = python-pyldap>=2.4.15
- depends = python-dnspython>=1.11.1
+ depends = python-dnspython>=1.15
depends = python-netifaces>=0.10.4
depends = python-pyusb
- provides = python-ipapython=4.4.3-1
- provides = python-ipaplatform=4.4.3-1
+ provides = python-ipapython=4.5.3-1
+ provides = python-ipaplatform=4.5.3-1
pkgname = python-ipaclient
pkgdesc = Python libraries used by IPA client
arch = any
- depends = freeipa-client-common=4.4.3-1
- depends = freeipa-common=4.4.3-1
- depends = python-ipalib=4.4.3-1
- depends = python-dnspython>=1.11.1
+ depends = freeipa-client-common=4.5.3-1
+ depends = freeipa-common=4.5.3-1
+ depends = python-ipalib=4.5.3-1
+ depends = python-dnspython>=1.15
+ depends = python-jinja
pkgname = python2-ipalib
pkgdesc = Python libraries used by IPA
arch = any
- depends = freeipa-common=4.4.3-1
- depends = python2-gssapi>=1.1.2
+ depends = freeipa-common=4.5.3-1
+ depends = python2-gssapi>=1.2.0
depends = gnupg
depends = keyutils
+ depends = python2>=2.7.9
depends = python2-nss>=0.16
- depends = python2-cryptography>=0.9
- depends = python2-lxml
- depends = python2-netaddr
+ depends = python2-cryptography>=1.4
+ depends = python2-netaddr>=0.7.16
depends = sssd
depends = python2-qrcode>=5.0.0
depends = python2-pyasn1
+ depends = python2-pyasn1-modules
depends = python2-dateutil
depends = python2-yubico>=1.2.3
depends = python2-dbus
depends = python2-setuptools
depends = python2-six
depends = python2-ldap>=2.4.15
- depends = python2-dnspython>=1.11.1
+ depends = python2-dnspython>=1.15
+ depends = python2-enum34
depends = python2-netifaces>=0.10.4
depends = python2-pyusb
- provides = python2-ipapython=4.4.3-1
- provides = python2-ipaplatform=4.4.3-1
+ provides = python2-ipapython=4.5.3-1
+ provides = python2-ipaplatform=4.5.3-1
conflicts = freeipa-python
replaces = freeipa-python
pkgname = python2-ipaclient
pkgdesc = Python libraries used by IPA client
arch = any
- depends = freeipa-client-common=4.4.3-1
- depends = freeipa-common=4.4.3-1
- depends = python2-ipalib=4.4.3-1
- depends = python2-dnspython>=1.11.1
+ depends = freeipa-client-common=4.5.3-1
+ depends = freeipa-common=4.5.3-1
+ depends = python2-ipalib=4.5.3-1
+ depends = python2-dnspython>=1.15
+ depends = python2-jinja
pkgname = freeipa-common
pkgdesc = Common files used by IPA
@@ -128,9 +131,9 @@ pkgname = freeipa-client-common
pkgname = freeipa-client
pkgdesc = IPA authentication for use on clients
install = freeipa-client.install
- depends = freeipa-client-common=4.4.3-1
- depends = freeipa-common=4.4.3-1
- depends = python2-ipaclient=4.4.3-1
+ depends = freeipa-client-common=4.5.3-1
+ depends = freeipa-common=4.5.3-1
+ depends = python2-ipaclient=4.5.3-1
depends = python2-ldap
depends = cyrus-sasl-gssapi
depends = ntp
@@ -144,7 +147,7 @@ pkgname = freeipa-client
depends = nss
depends = bind-tools
depends = oddjob
- depends = python2-gssapi>=1.1.2
+ depends = python2-gssapi>=1.2.0
depends = autofs
depends = nfsidmap
depends = nfs-utils