summarylogtreecommitdiffstats
path: root/.SRCINFO
diff options
context:
space:
mode:
Diffstat (limited to '.SRCINFO')
-rw-r--r--.SRCINFO34
1 files changed, 18 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 390508310fe..69b08773bce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = llvm-git
- pkgver = 9.0.0_r321420.937ff6e701b
+ pkgver = 10.0.0_r325028.b43923da5bb
pkgrel = 1
url = https://llvm.org/
arch = x86_64
@@ -12,7 +12,7 @@ pkgbase = llvm-git
makedepends = ncurses
makedepends = libxml2
makedepends = python-sphinx
- makedepends = ocaml=4.07.1
+ makedepends = ocaml
makedepends = ocaml-ctypes
makedepends = ocaml-findlib
makedepends = python-sphinx
@@ -22,30 +22,32 @@ pkgbase = llvm-git
source = llvm-project::git+https://github.com/llvm/llvm-project.git
source = llvm-config.h
source = enable-SSP-and-PIE-by-default.patch
+ source = always-initialize-all-members-in-ABIArgInfo.patch
sha256sums = SKIP
sha256sums = 597dc5968c695bbdbb0eac9e8eb5117fcd2773bc91edf5ec103ecffffab8bc48
sha256sums = 58f86da25eb230ed6d423b5b61870cbf3bef88f38103ca676a2c7f34b2372171
+ sha256sums = 355553ff360002000d57fc00cd5c753a261c85aafbb9c8b328bef7b8b5a403c1
pkgname = llvm-git
pkgdesc = LLVM development version. includes clang and many other tools
- depends = llvm-libs-git=9.0.0_r321420.937ff6e701b-1
+ depends = llvm-libs-git=10.0.0_r325028.b43923da5bb-1
depends = perl
optdepends = python: for scripts
optdepends = python-setuptools: for using lit (LLVM Integrated Tester)
optdepends = ocaml: for ocaml support
provides = aur-llvm-git
- provides = compiler-rt-git=9.0.0_r321420.937ff6e701b-1
- provides = clang-git=9.0.0_r321420.937ff6e701b-1
- provides = lld-git=9.0.0_r321420.937ff6e701b-1
- provides = lldb-git=9.0.0_r321420.937ff6e701b-1
- provides = polly-git=9.0.0_r321420.937ff6e701b-1
- provides = llvm-ocaml-git=9.0.0_r321420.937ff6e701b-1
- provides = compiler-rt=9.0.0_r321420.937ff6e701b-1
- provides = clang=9.0.0_r321420.937ff6e701b-1
- provides = lld=9.0.0_r321420.937ff6e701b-1
- provides = lldb=9.0.0_r321420.937ff6e701b-1
- provides = polly=9.0.0_r321420.937ff6e701b-1
- provides = llvm-ocaml=9.0.0_r321420.937ff6e701b-1
+ provides = compiler-rt-git=10.0.0_r325028.b43923da5bb-1
+ provides = clang-git=10.0.0_r325028.b43923da5bb-1
+ provides = lld-git=10.0.0_r325028.b43923da5bb-1
+ provides = lldb-git=10.0.0_r325028.b43923da5bb-1
+ provides = polly-git=10.0.0_r325028.b43923da5bb-1
+ provides = llvm-ocaml-git=10.0.0_r325028.b43923da5bb-1
+ provides = compiler-rt=10.0.0_r325028.b43923da5bb-1
+ provides = clang=10.0.0_r325028.b43923da5bb-1
+ provides = lld=10.0.0_r325028.b43923da5bb-1
+ provides = lldb=10.0.0_r325028.b43923da5bb-1
+ provides = polly=10.0.0_r325028.b43923da5bb-1
+ provides = llvm-ocaml=10.0.0_r325028.b43923da5bb-1
conflicts = llvm
conflicts = compiler-rt
conflicts = clang
@@ -63,6 +65,6 @@ pkgname = llvm-libs-git
depends = ncurses
depends = libxml2
provides = aur-llvm-libs-git
- provides = llvm-libs=9.0.0_r321420.937ff6e701b-1
+ provides = llvm-libs=10.0.0_r325028.b43923da5bb-1
conflicts = llvm-libs