summarylogtreecommitdiffstats
path: root/.drone.yml
diff options
context:
space:
mode:
Diffstat (limited to '.drone.yml')
-rw-r--r--.drone.yml18
1 files changed, 18 insertions, 0 deletions
diff --git a/.drone.yml b/.drone.yml
new file mode 100644
index 000000000000..153d6fdd46e6
--- /dev/null
+++ b/.drone.yml
@@ -0,0 +1,18 @@
+kind: pipeline
+type: docker
+name: default
+
+steps:
+- name: fixperms
+ image: imrehg/archlinux-makepkg
+ user: root
+ commands:
+ - chown -R builder:builder .
+- name: build
+ image: imrehg/archlinux-makepkg
+ commands:
+ - yay -Suy --noconfirm
+ - namcap PKGBUILD
+ - makepkg -sci --noconfirm
+ - namcap *.pkg.tar.xz
+