summarylogtreecommitdiffstats
path: root/.drone.yml
diff options
context:
space:
mode:
Diffstat (limited to '.drone.yml')
-rw-r--r--.drone.yml28
1 files changed, 28 insertions, 0 deletions
diff --git a/.drone.yml b/.drone.yml
new file mode 100644
index 000000000000..bb48fcec3b18
--- /dev/null
+++ b/.drone.yml
@@ -0,0 +1,28 @@
+kind: pipeline
+name: default
+
+steps:
+- name: build
+ image: archlinux/base
+ commands:
+ - mkdir build
+ - chgrp nobody build
+ - chmod g+ws build
+ - setfacl -m u::rwx,g::rwx build
+ - setfacl -d --set u::rwx,g::rwx,o::r build
+ - ls
+ - pacman -Sy --noconfirm binutils sudo grep fakeroot file
+ - pacman -S --noconfirm upower
+ - mv PKGBUILD build/
+ - pushd build
+ - sudo -u nobody makepkg -c
+ - ls -la
+ - popd
+ - mv build/kbdlightx1-* ./
+ - mv build/PKGBUILD ./
+- name: test
+ image: archlinux/base
+ commands:
+ - pacman -Sy --noconfirm namcap grep
+ - namcap PKGBUILD
+ - namcap kbdlightx1-* \ No newline at end of file