aboutsummarylogtreecommitdiffstats
path: root/.editorconfig
diff options
context:
space:
mode:
Diffstat (limited to '.editorconfig')
-rw-r--r--.editorconfig29
1 files changed, 29 insertions, 0 deletions
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..91faecdb8879
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,29 @@
+# EditorConfig is awesome: http://EditorConfig.org
+
+# top-most EditorConfig file
+root = true
+
+# Unix-style newlines with a newline ending every file
+[*]
+end_of_line = lf
+insert_final_newline = true
+trim_trailing_whitespace = true
+
+# c/c++ settings
+[*.{c,cpp,h,hpp,ipp}]
+indent_style = tab
+indent_size = 4
+charset = utf-8
+
+# 4 space indentation
+[*.py]
+indent_style = space
+indent_size = 4
+charset = utf-8
+
+# 2 space indentation
+[PKGBUILD]
+indent_style = space
+indent_size = 2
+charset = utf-8
+