summarylogtreecommitdiffstats
path: root/.travis_deploy.sh
diff options
context:
space:
mode:
Diffstat (limited to '.travis_deploy.sh')
-rw-r--r--.travis_deploy.sh8
1 files changed, 8 insertions, 0 deletions
diff --git a/.travis_deploy.sh b/.travis_deploy.sh
new file mode 100644
index 000000000000..ac569f54e1a4
--- /dev/null
+++ b/.travis_deploy.sh
@@ -0,0 +1,8 @@
+. PKGBUILD
+git clone https://$GITHUB_ACCESS_TOKEN@github.com/bartoszek/AUR-repo.git
+cd AUR-repo
+cp $TRAVIS_BUILD_DIR/$pkgname-$pkgver*.pkg.tar.xz $(pwd)
+git add $pkgname-$pkgver*.pkg.tar.xz
+git status
+git commit -a -m "$pkgname $pkgver" -m "build_log: $TRAVIS_BUILD_WEB_URL"
+git push