summarylogtreecommitdiffstats
path: root/000-packaging.patch
diff options
context:
space:
mode:
Diffstat (limited to '000-packaging.patch')
-rw-r--r--000-packaging.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/000-packaging.patch b/000-packaging.patch
new file mode 100644
index 000000000000..bdb3611a451c
--- /dev/null
+++ b/000-packaging.patch
@@ -0,0 +1,33 @@
+diff --git a/meson.build b/meson.build
+index 4eb5213..692058c 100644
+--- a/meson.build
++++ b/meson.build
+@@ -11,18 +11,25 @@ bitdis_sources = [
+ 'src/reorder.c',
+ 'src/reorder.h'
+ ]
+-executable('bitdis', bitdis_sources)
++executable('bitdis', bitdis_sources, install : true)
+
+ bitspl_sources = [
+ 'src/bitspl.c',
+ 'src/reorder.c',
+ 'src/reorder.h'
+ ]
+-executable('bitspl', bitspl_sources)
++executable('bitspl', bitspl_sources, install : true)
+
+ coda_fwinfo_sources = [
+ 'src/coda-fwinfo.c',
+ 'src/reorder.c',
+ 'src/reorder.h'
+ ]
+-executable('coda-fwinfo', coda_fwinfo_sources)
++executable('coda-fwinfo', coda_fwinfo_sources, install : true)
++
++codabits_docs = [
++ 'README.rst',
++ 'doc/bit-isa.rst',
++ 'doc/bit.rst'
++]
++install_data(codabits_docs, install_dir: 'share/doc/coda-bits')