summarylogtreecommitdiffstats
path: root/0001-AUR-Pkgbuild-changes.patch
diff options
context:
space:
mode:
Diffstat (limited to '0001-AUR-Pkgbuild-changes.patch')
-rw-r--r--0001-AUR-Pkgbuild-changes.patch40
1 files changed, 20 insertions, 20 deletions
diff --git a/0001-AUR-Pkgbuild-changes.patch b/0001-AUR-Pkgbuild-changes.patch
index dc59722970e2..1957fde77e49 100644
--- a/0001-AUR-Pkgbuild-changes.patch
+++ b/0001-AUR-Pkgbuild-changes.patch
@@ -1,4 +1,4 @@
-From d67d53fabc20631ec747db7db30111ed1e8941dd Mon Sep 17 00:00:00 2001
+From c93e7c51c12dfcc66bba3816ab611577838eb824 Mon Sep 17 00:00:00 2001
From: Stelios Tsampas <loathingkernel@gmail.com>
Date: Tue, 7 Feb 2023 22:00:48 +0200
Subject: [PATCH 1/6] AUR Pkgbuild changes
@@ -20,7 +20,7 @@ Subject: [PATCH 1/6] AUR Pkgbuild changes
13 files changed, 89 insertions(+), 42 deletions(-)
diff --git a/Makefile.in b/Makefile.in
-index 3d69e90c..a96465c7 100644
+index a9c50e19..e568dfb6 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -50,11 +50,12 @@ else
@@ -109,7 +109,7 @@ index 3d69e90c..a96465c7 100644
-Dadder=enabled \
-Dapp=enabled \
-Daudioconvert=enabled \
-@@ -200,6 +220,7 @@ $(eval $(call rules-meson,gst_base,64))
+@@ -201,6 +221,7 @@ $(eval $(call rules-meson,gst_base,64))
##
GST_GOOD_MESON_ARGS := \
@@ -117,7 +117,7 @@ index 3d69e90c..a96465c7 100644
-Dauto_features=disabled \
-Dgobject-cast-checks=disabled \
-Dglib-asserts=disabled \
-@@ -246,6 +267,7 @@ $(eval $(call rules-meson,gst_good,64))
+@@ -247,6 +268,7 @@ $(eval $(call rules-meson,gst_good,64))
FFMPEG_CONFIGURE_ARGS := \
--enable-shared \
@@ -125,7 +125,7 @@ index 3d69e90c..a96465c7 100644
--disable-static \
--disable-everything \
--disable-programs \
-@@ -275,6 +297,11 @@ FFMPEG_CONFIGURE_ARGS := \
+@@ -276,6 +298,11 @@ FFMPEG_CONFIGURE_ARGS := \
--enable-decoder=aac \
--enable-demuxer=xwma
@@ -137,7 +137,7 @@ index 3d69e90c..a96465c7 100644
$(eval $(call rules-source,ffmpeg,$(SRCDIR)/ffmpeg))
$(eval $(call rules-configure,ffmpeg,32))
$(eval $(call rules-configure,ffmpeg,64))
-@@ -319,6 +346,7 @@ $(OBJ)/.gst_plugins_rs-post-build32:
+@@ -320,6 +347,7 @@ $(OBJ)/.gst_plugins_rs-post-build32:
##
GST_BAD_MESON_ARGS := \
@@ -145,7 +145,7 @@ index 3d69e90c..a96465c7 100644
-Dauto_features=disabled \
-Dintrospection=disabled \
-Dgobject-cast-checks=disabled \
-@@ -431,6 +459,7 @@ $(eval $(call rules-meson,gst_bad,64))
+@@ -432,6 +460,7 @@ $(eval $(call rules-meson,gst_bad,64))
##
GST_UGLY_MESON_ARGS := \
@@ -153,7 +153,7 @@ index 3d69e90c..a96465c7 100644
-Dauto_features=disabled \
-Dgobject-cast-checks=disabled \
-Dglib-asserts=disabled \
-@@ -520,7 +549,7 @@ $(eval $(call rules-cmake,openxr,64))
+@@ -521,7 +550,7 @@ $(eval $(call rules-cmake,openxr,64))
## Note 32-bit is not supported by SteamVR, so we don't build it.
##
@@ -162,7 +162,7 @@ index 3d69e90c..a96465c7 100644
WINEOPENXR_DEPENDS = wine openxr
$(eval $(call rules-source,wineopenxr,$(SRCDIR)/wineopenxr))
-@@ -598,6 +627,9 @@ OPENFST_CONFIGURE_ARGS = \
+@@ -599,6 +628,9 @@ OPENFST_CONFIGURE_ARGS = \
--with-pic \
--disable-bin \
@@ -172,7 +172,7 @@ index 3d69e90c..a96465c7 100644
$(eval $(call rules-source,openfst,$(SRCDIR)/openfst))
$(eval $(call rules-autoconf,openfst,32))
$(eval $(call rules-autoconf,openfst,64))
-@@ -660,7 +692,10 @@ WINE_SOURCE_ARGS = \
+@@ -661,7 +693,10 @@ WINE_SOURCE_ARGS = \
--exclude dlls/winevulkan/winevulkan.spec
WINE_CONFIGURE_ARGS = \
@@ -183,7 +183,7 @@ index 3d69e90c..a96465c7 100644
--disable-tests
WINE_CONFIGURE_ARGS32 = \
-@@ -717,6 +752,9 @@ DXVK_MESON_ARGS32 = --bindir=$(DXVK_DST32)/lib/wine/dxvk
+@@ -718,6 +753,9 @@ DXVK_MESON_ARGS32 = --bindir=$(DXVK_DST32)/lib/wine/dxvk
DXVK_MESON_ARGS64 = --bindir=$(DXVK_DST64)/lib64/wine/dxvk
DXVK_DEPENDS = glslang
@@ -193,7 +193,7 @@ index 3d69e90c..a96465c7 100644
$(eval $(call rules-source,dxvk,$(SRCDIR)/dxvk))
$(eval $(call rules-meson,dxvk,32,CROSS))
$(eval $(call rules-meson,dxvk,64,CROSS))
-@@ -744,6 +782,9 @@ $(OBJ)/.dxvk-post-build32:
+@@ -745,6 +783,9 @@ $(OBJ)/.dxvk-post-build32:
DXVK_NVAPI_MESON_ARGS32 = --bindir=$(DXVK_NVAPI_DST32)/lib/wine/nvapi
DXVK_NVAPI_MESON_ARGS64 = --bindir=$(DXVK_NVAPI_DST64)/lib64/wine/nvapi
@@ -203,7 +203,7 @@ index 3d69e90c..a96465c7 100644
$(eval $(call rules-source,dxvk-nvapi,$(SRCDIR)/dxvk-nvapi))
$(eval $(call rules-meson,dxvk-nvapi,32,CROSS))
$(eval $(call rules-meson,dxvk-nvapi,64,CROSS))
-@@ -772,6 +813,9 @@ D8VK_MESON_ARGS32 = --bindir=$(D8VK_DST32)/lib/wine/d8vk
+@@ -773,6 +814,9 @@ D8VK_MESON_ARGS32 = --bindir=$(D8VK_DST32)/lib/wine/d8vk
D8VK_MESON_ARGS64 = --bindir=$(D8VK_DST64)/lib64/wine/d8vk
D8VK_DEPENDS = glslang
@@ -213,7 +213,7 @@ index 3d69e90c..a96465c7 100644
$(eval $(call rules-source,d8vk,$(SRCDIR)/d8vk))
$(eval $(call rules-meson,d8vk,32,CROSS))
$(eval $(call rules-meson,d8vk,64,CROSS))
-@@ -851,6 +895,9 @@ ifneq ($(UNSTRIPPED_BUILD),)
+@@ -852,6 +896,9 @@ ifneq ($(UNSTRIPPED_BUILD),)
VKD3D_PROTON_MESON_ARGS = -Denable_trace=true
endif
@@ -223,7 +223,7 @@ index 3d69e90c..a96465c7 100644
$(eval $(call rules-source,vkd3d-proton,$(SRCDIR)/vkd3d-proton))
$(eval $(call rules-meson,vkd3d-proton,32,CROSS))
$(eval $(call rules-meson,vkd3d-proton,64,CROSS))
-@@ -1147,14 +1194,14 @@ $(FONTS_OBJ)/source-han/%.ttf: $$(%.ttf_CIDFONT) $$(%.ttf_FEATURES) $$(%.ttf_SEQ
+@@ -1148,14 +1195,14 @@ $(FONTS_OBJ)/source-han/%.ttf: $$(%.ttf_CIDFONT) $$(%.ttf_FEATURES) $$(%.ttf_SEQ
mkdir -p $(FONTS_OBJ)/source-han
# Do not immediately create the target file, so that make is interrupted
# it will restart again
@@ -241,7 +241,7 @@ index 3d69e90c..a96465c7 100644
mv $@.tmp $@
$(FONTS_OBJ)/ume-gothic/%.ttf: $$(%.ttf_FONT) $$(%.ttf_NAMETABLE_PATCH)
-@@ -1164,12 +1211,12 @@ $(FONTS_OBJ)/ume-gothic/%.ttf: $$(%.ttf_FONT) $$(%.ttf_NAMETABLE_PATCH)
+@@ -1165,12 +1212,12 @@ $(FONTS_OBJ)/ume-gothic/%.ttf: $$(%.ttf_FONT) $$(%.ttf_NAMETABLE_PATCH)
ttx -o $@ -m $($(notdir $@)_FONT) $(FONTS_OBJ)/ume-gothic/$(notdir $(basename $($(notdir $@)_NAMETABLE_PATCH))).ttx
$(simsun.ttc): $(simsun.ttf) $(nsimsun.ttf)
@@ -257,7 +257,7 @@ index 3d69e90c..a96465c7 100644
$(micross.ttf): $(FONTS)/scripts/merge.py $(noto_sans.ttf) $(noto_sans_arabic.ttf) $(noto_sans_armenian.ttf) $(noto_sans_bengali.ttf) $(noto_sans_coptic.ttf) \
$(noto_sans_georgian.ttf) $(noto_sans_gujarati.ttf) $(noto_sans_hebrew.ttf) $(noto_sans_khmer.ttf) $(noto_sans_tamil.ttf) \
-@@ -1295,8 +1342,8 @@ all-dist: $(DIST_OVR32) $(DIST_OVR64)
+@@ -1296,8 +1343,8 @@ all-dist: $(DIST_OVR32) $(DIST_OVR64)
##
default_pfx: wine gst_good gst_libav gst_plugins_rs lsteamclient steamexe vrclient wineopenxr dxvk dxvk-nvapi vkd3d-proton d8vk
@@ -268,7 +268,7 @@ index 3d69e90c..a96465c7 100644
rm -rf $(abspath $(DIST_PREFIX))
python3 $(SRCDIR)/default_pfx.py $(abspath $(DIST_PREFIX)) $(abspath $(DST_DIR))
-@@ -1438,7 +1485,6 @@ ifeq ($(ENABLE_CCACHE),1)
+@@ -1439,7 +1486,6 @@ ifeq ($(ENABLE_CCACHE),1)
export CCACHE_DIR := $(if $(CCACHE_DIR),$(CCACHE_DIR),$(HOME)/.ccache)
override DOCKER_OPTS := -v $(CCACHE_DIR):$(CCACHE_DIR)$(CONTAINER_MOUNT_OPTS) $(CCACHE_ENV) -e CCACHE_DIR=$(CCACHE_DIR) $(DOCKER_OPTS)
else
@@ -276,7 +276,7 @@ index 3d69e90c..a96465c7 100644
override DOCKER_OPTS := $(CCACHE_ENV) -e CCACHE_DISABLE=1 $(DOCKER_OPTS)
endif
-@@ -1453,9 +1499,6 @@ ifeq ($(CONTAINER_ENGINE),)
+@@ -1454,9 +1500,6 @@ ifeq ($(CONTAINER_ENGINE),)
CONTAINER_ENGINE := docker
endif
@@ -488,7 +488,7 @@ index 5c3b59a3..ed6589e0 100644
winebuild --$(lastword $(subst ., ,$(4))) --fake-module -E "$(basename $(4)).spec" -o "$(4).fake"
mkdir -p $$($(2)_LIBDIR$(3))/$(LIBDIR_WINE_$(3))
diff --git a/proton b/proton
-index 009bb53b..a97f6dda 100755
+index 2c231af4..31c48410 100755
--- a/proton
+++ b/proton
@@ -423,7 +423,6 @@ class Proton: