summarylogtreecommitdiffstats
path: root/0001-AUR-Pkgbuild-changes.patch
diff options
context:
space:
mode:
Diffstat (limited to '0001-AUR-Pkgbuild-changes.patch')
-rw-r--r--0001-AUR-Pkgbuild-changes.patch35
1 files changed, 18 insertions, 17 deletions
diff --git a/0001-AUR-Pkgbuild-changes.patch b/0001-AUR-Pkgbuild-changes.patch
index bfd0a82a3e32..c27d76c29734 100644
--- a/0001-AUR-Pkgbuild-changes.patch
+++ b/0001-AUR-Pkgbuild-changes.patch
@@ -1,10 +1,10 @@
-From 9a4fc83b5e88ff440481364cd6a19487df758452 Mon Sep 17 00:00:00 2001
+From 108bd702494d8b6a1cbb776c6b3801b2e0ee7c80 Mon Sep 17 00:00:00 2001
From: Stelios Tsampas <loathingkernel@gmail.com>
Date: Tue, 7 Feb 2023 22:00:48 +0200
Subject: [PATCH 1/6] AUR Pkgbuild changes
---
- Makefile.in | 86 +++++++++++++++++++++++++++-------
+ Makefile.in | 87 +++++++++++++++++++++++++++-------
compatibilitytool.vdf.template | 2 +-
configure.sh | 2 +
make/rules-autoconf.mk | 4 +-
@@ -17,10 +17,10 @@ Subject: [PATCH 1/6] AUR Pkgbuild changes
make/rules-winemaker.mk | 2 +-
proton | 6 +--
toolmanifest_runtime.vdf | 3 --
- 13 files changed, 100 insertions(+), 42 deletions(-)
+ 13 files changed, 101 insertions(+), 42 deletions(-)
diff --git a/Makefile.in b/Makefile.in
-index 256acc2b..a07dece7 100644
+index 256acc2b..b08d8b88 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -50,11 +50,12 @@ else
@@ -158,20 +158,21 @@ index 256acc2b..a07dece7 100644
-Dfbdev=disabled \
-Ddecklink=disabled \
-Dcurl=disabled \
-@@ -362,7 +398,12 @@ GST_BAD_MESON_ARGS := \
+@@ -362,7 +398,13 @@ GST_BAD_MESON_ARGS := \
-Dvoamrwbenc=disabled \
-Dnvcodec=disabled \
-Dx265=disabled \
+ -Dopenexr=disabled \
+ -Dzxing=disabled \
+ -Dva=disabled \
++ -Dqsv=disabled \
+ -Dexamples=disabled \
-Dtests=disabled \
+ -Dintrospection=disabled \
-Dgobject-cast-checks=disabled \
-Dglib-asserts=disabled \
-Dglib-checks=disabled \
-@@ -380,6 +421,7 @@ $(eval $(call rules-meson,gst_bad,64))
+@@ -380,6 +422,7 @@ $(eval $(call rules-meson,gst_bad,64))
##
GST_UGLY_MESON_ARGS := \
@@ -179,7 +180,7 @@ index 256acc2b..a07dece7 100644
-Ddoc='disabled' \
-Dtests=disabled \
-Dgobject-cast-checks=disabled \
-@@ -542,6 +584,9 @@ OPENFST_CONFIGURE_ARGS = \
+@@ -542,6 +585,9 @@ OPENFST_CONFIGURE_ARGS = \
--with-pic \
--disable-bin \
@@ -189,7 +190,7 @@ index 256acc2b..a07dece7 100644
$(eval $(call rules-source,openfst,$(SRCDIR)/openfst))
$(eval $(call rules-autoconf,openfst,32))
$(eval $(call rules-autoconf,openfst,64))
-@@ -604,7 +649,11 @@ WINE_SOURCE_ARGS = \
+@@ -604,7 +650,11 @@ WINE_SOURCE_ARGS = \
--exclude dlls/winevulkan/winevulkan.spec
WINE_CONFIGURE_ARGS = \
@@ -201,7 +202,7 @@ index 256acc2b..a07dece7 100644
--disable-tests
WINE_CONFIGURE_ARGS32 = \
-@@ -661,6 +710,9 @@ DXVK_MESON_ARGS32 = --bindir=$(DXVK_DST32)/lib/wine/dxvk
+@@ -661,6 +711,9 @@ DXVK_MESON_ARGS32 = --bindir=$(DXVK_DST32)/lib/wine/dxvk
DXVK_MESON_ARGS64 = --bindir=$(DXVK_DST64)/lib64/wine/dxvk
DXVK_DEPENDS = glslang
@@ -211,7 +212,7 @@ index 256acc2b..a07dece7 100644
$(eval $(call rules-source,dxvk,$(SRCDIR)/dxvk))
$(eval $(call rules-meson,dxvk,32,CROSS))
$(eval $(call rules-meson,dxvk,64,CROSS))
-@@ -688,6 +740,9 @@ $(OBJ)/.dxvk-post-build32:
+@@ -688,6 +741,9 @@ $(OBJ)/.dxvk-post-build32:
DXVK_NVAPI_MESON_ARGS32 = --bindir=$(DXVK_NVAPI_DST32)/lib/wine/nvapi
DXVK_NVAPI_MESON_ARGS64 = --bindir=$(DXVK_NVAPI_DST64)/lib64/wine/nvapi
@@ -221,7 +222,7 @@ index 256acc2b..a07dece7 100644
$(eval $(call rules-source,dxvk-nvapi,$(SRCDIR)/dxvk-nvapi))
$(eval $(call rules-meson,dxvk-nvapi,32,CROSS))
$(eval $(call rules-meson,dxvk-nvapi,64,CROSS))
-@@ -762,6 +817,9 @@ ifneq ($(UNSTRIPPED_BUILD),)
+@@ -762,6 +818,9 @@ ifneq ($(UNSTRIPPED_BUILD),)
VKD3D_PROTON_MESON_ARGS = -Denable_trace=true
endif
@@ -231,7 +232,7 @@ index 256acc2b..a07dece7 100644
$(eval $(call rules-source,vkd3d-proton,$(SRCDIR)/vkd3d-proton))
$(eval $(call rules-meson,vkd3d-proton,32,CROSS))
$(eval $(call rules-meson,vkd3d-proton,64,CROSS))
-@@ -1058,14 +1116,14 @@ $(FONTS_OBJ)/source-han/%.ttf: $$(%.ttf_CIDFONT) $$(%.ttf_FEATURES) $$(%.ttf_SEQ
+@@ -1058,14 +1117,14 @@ $(FONTS_OBJ)/source-han/%.ttf: $$(%.ttf_CIDFONT) $$(%.ttf_FEATURES) $$(%.ttf_SEQ
mkdir -p $(FONTS_OBJ)/source-han
# Do not immediately create the target file, so that make is interrupted
# it will restart again
@@ -249,7 +250,7 @@ index 256acc2b..a07dece7 100644
mv $@.tmp $@
$(FONTS_OBJ)/ume-gothic/%.ttf: $$(%.ttf_FONT) $$(%.ttf_NAMETABLE_PATCH)
-@@ -1075,12 +1133,12 @@ $(FONTS_OBJ)/ume-gothic/%.ttf: $$(%.ttf_FONT) $$(%.ttf_NAMETABLE_PATCH)
+@@ -1075,12 +1134,12 @@ $(FONTS_OBJ)/ume-gothic/%.ttf: $$(%.ttf_FONT) $$(%.ttf_NAMETABLE_PATCH)
ttx -o $@ -m $($(notdir $@)_FONT) $(FONTS_OBJ)/ume-gothic/$(notdir $(basename $($(notdir $@)_NAMETABLE_PATCH))).ttx
$(simsun.ttc): $(simsun.ttf) $(nsimsun.ttf)
@@ -265,7 +266,7 @@ index 256acc2b..a07dece7 100644
$(micross.ttf): $(FONTS)/scripts/merge.py $(noto_sans.ttf) $(noto_sans_arabic.ttf) $(noto_sans_armenian.ttf) $(noto_sans_bengali.ttf) $(noto_sans_coptic.ttf) \
$(noto_sans_georgian.ttf) $(noto_sans_gujarati.ttf) $(noto_sans_hebrew.ttf) $(noto_sans_khmer.ttf) $(noto_sans_tamil.ttf) \
-@@ -1206,8 +1264,8 @@ all-dist: $(DIST_OVR32) $(DIST_OVR64)
+@@ -1206,8 +1265,8 @@ all-dist: $(DIST_OVR32) $(DIST_OVR64)
##
default_pfx: wine gst_good gst_libav gst_plugins_rs lsteamclient steamexe vrclient wineopenxr dxvk dxvk-nvapi vkd3d-proton
@@ -276,7 +277,7 @@ index 256acc2b..a07dece7 100644
rm -rf $(abspath $(DIST_PREFIX))
python3 $(SRCDIR)/default_pfx.py $(abspath $(DIST_PREFIX)) $(abspath $(DST_DIR))
-@@ -1349,7 +1407,6 @@ ifeq ($(ENABLE_CCACHE),1)
+@@ -1349,7 +1408,6 @@ ifeq ($(ENABLE_CCACHE),1)
export CCACHE_DIR := $(if $(CCACHE_DIR),$(CCACHE_DIR),$(HOME)/.ccache)
override DOCKER_OPTS := -v $(CCACHE_DIR):$(CCACHE_DIR)$(CONTAINER_MOUNT_OPTS) $(CCACHE_ENV) -e CCACHE_DIR=$(CCACHE_DIR) $(DOCKER_OPTS)
else
@@ -284,7 +285,7 @@ index 256acc2b..a07dece7 100644
override DOCKER_OPTS := $(CCACHE_ENV) -e CCACHE_DISABLE=1 $(DOCKER_OPTS)
endif
-@@ -1364,9 +1421,6 @@ ifeq ($(CONTAINER_ENGINE),)
+@@ -1364,9 +1422,6 @@ ifeq ($(CONTAINER_ENGINE),)
CONTAINER_ENGINE := docker
endif
@@ -496,7 +497,7 @@ index 5c3b59a3..ed6589e0 100644
winebuild --$(lastword $(subst ., ,$(4))) --fake-module -E "$(basename $(4)).spec" -o "$(4).fake"
mkdir -p $$($(2)_LIBDIR$(3))/$(LIBDIR_WINE_$(3))
diff --git a/proton b/proton
-index 34bb6e9c..40cd310c 100755
+index cfe865bc..5912d15d 100755
--- a/proton
+++ b/proton
@@ -423,7 +423,6 @@ class Proton: