summarylogtreecommitdiffstats
path: root/0001-Add-build-option-for-udev-path.patch
diff options
context:
space:
mode:
Diffstat (limited to '0001-Add-build-option-for-udev-path.patch')
-rw-r--r--0001-Add-build-option-for-udev-path.patch27
1 files changed, 0 insertions, 27 deletions
diff --git a/0001-Add-build-option-for-udev-path.patch b/0001-Add-build-option-for-udev-path.patch
deleted file mode 100644
index 1fb919fb4b11..000000000000
--- a/0001-Add-build-option-for-udev-path.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 9a1cb8e..63c971d 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -229,6 +229,9 @@ else()
- set(INSTALL_MAN_DIR "share/man/man1")
- endif()
- set(INSTALL_DATA_DIR "share/${PROJECT_NAME}")
-+ if (NOT DEFINED UDEV_RULES_DIR OR "${UDEV_RULES_DIR}" STREQUAL "")
-+ set(UDEV_RULES_DIR "/etc/udev/rules.d")
-+ endif()
- endif(WIN32 OR CYGWIN)
-
- # requirements
-diff --git a/conf/CMakeLists.txt b/conf/CMakeLists.txt
-index d4a229d..a84497f 100644
---- a/conf/CMakeLists.txt
-+++ b/conf/CMakeLists.txt
-@@ -26,7 +26,7 @@ file(WRITE "${CMAKE_BINARY_DIR}/direwolf.conf" "${file_content}")
-
- # install udev rules for CM108
- if(LINUX)
-- install(FILES "${CUSTOM_CONF_DIR}/99-direwolf-cmedia.rules" DESTINATION /etc/udev/rules.d/)
-+ install(FILES "${CUSTOM_CONF_DIR}/99-direwolf-cmedia.rules" DESTINATION ${UDEV_RULES_DIR})
- endif()
-
- install(FILES "${CMAKE_BINARY_DIR}/direwolf.conf" DESTINATION ${INSTALL_CONF_DIR})