summarylogtreecommitdiffstats
path: root/0001-Cairo-backend-added-to-Qt5-wrapper.patch
diff options
context:
space:
mode:
Diffstat (limited to '0001-Cairo-backend-added-to-Qt5-wrapper.patch')
-rw-r--r--0001-Cairo-backend-added-to-Qt5-wrapper.patch42
1 files changed, 21 insertions, 21 deletions
diff --git a/0001-Cairo-backend-added-to-Qt5-wrapper.patch b/0001-Cairo-backend-added-to-Qt5-wrapper.patch
index 7ed3036d1728..aac389a10ab3 100644
--- a/0001-Cairo-backend-added-to-Qt5-wrapper.patch
+++ b/0001-Cairo-backend-added-to-Qt5-wrapper.patch
@@ -1,7 +1,7 @@
-From 658937f5adbf1f77302c07095447b59e607749de Mon Sep 17 00:00:00 2001
+From bced35b82a9bd386894f535794fd61feed482525 Mon Sep 17 00:00:00 2001
From: Paul Gideon Dann <pdgiddie@gmail.com>
Date: Wed, 4 Apr 2018 16:36:56 +0100
-Subject: [PATCH 1/4] Cairo backend added to Qt5 wrapper
+Subject: [PATCH 1/5] Cairo backend added to Qt5 wrapper
---
qt5/src/CMakeLists.txt | 15 ++++++++
@@ -12,7 +12,7 @@ Subject: [PATCH 1/4] Cairo backend added to Qt5 wrapper
5 files changed, 95 insertions(+), 1 deletion(-)
diff --git a/qt5/src/CMakeLists.txt b/qt5/src/CMakeLists.txt
-index 38bb6b14..e40fd82b 100644
+index 6f34054e..70d635ad 100644
--- a/qt5/src/CMakeLists.txt
+++ b/qt5/src/CMakeLists.txt
@@ -7,6 +7,11 @@ include_directories(
@@ -24,10 +24,10 @@ index 38bb6b14..e40fd82b 100644
+ add_definitions(${CAIRO_CFLAGS})
+endif (HAVE_CAIRO)
+
- set(poppler_qt5_SRCS
- poppler-annotation.cc
- poppler-document.cc
-@@ -29,6 +34,13 @@ set(poppler_qt5_SRCS
+ set(CMAKE_C_VISIBILITY_PRESET hidden)
+ set(CMAKE_CXX_VISIBILITY_PRESET hidden)
+ set(CMAKE_VISIBILITY_INLINES_HIDDEN 1)
+@@ -33,6 +38,13 @@ set(poppler_qt5_SRCS
poppler-media.cc
ArthurOutputDev.cc
)
@@ -39,9 +39,9 @@ index 38bb6b14..e40fd82b 100644
+ )
+endif(HAVE_CAIRO)
add_library(poppler-qt5 ${poppler_qt5_SRCS})
- set_target_properties(poppler-qt5 PROPERTIES VERSION 1.15.0 SOVERSION 1)
+ set_target_properties(poppler-qt5 PROPERTIES VERSION 1.17.0 SOVERSION 1)
if(MINGW)
-@@ -36,6 +48,9 @@ if(MINGW)
+@@ -40,6 +52,9 @@ if(MINGW)
set_target_properties(poppler-qt5 PROPERTIES SUFFIX "-${POPPLER_QT5_SOVERSION}${CMAKE_SHARED_LIBRARY_SUFFIX}")
endif()
target_link_libraries(poppler-qt5 poppler ${Qt5Core_LIBRARIES} ${Qt5Gui_LIBRARIES} ${Qt5Xml_LIBRARIES})
@@ -52,10 +52,10 @@ index 38bb6b14..e40fd82b 100644
target_link_libraries(poppler-qt5 poppler ${poppler_LIBS})
endif()
diff --git a/qt5/src/poppler-document.cc b/qt5/src/poppler-document.cc
-index 102bd820..4f20ebe7 100644
+index c7b90ca9..afad9f5d 100644
--- a/qt5/src/poppler-document.cc
+++ b/qt5/src/poppler-document.cc
-@@ -673,6 +673,9 @@ namespace Poppler {
+@@ -677,6 +677,9 @@ namespace Poppler {
ret << Document::SplashBackend;
#endif
ret << Document::ArthurBackend;
@@ -66,10 +66,10 @@ index 102bd820..4f20ebe7 100644
}
diff --git a/qt5/src/poppler-page.cc b/qt5/src/poppler-page.cc
-index b48ee959..d2d52069 100644
+index 34f58053..37b1d06a 100644
--- a/qt5/src/poppler-page.cc
+++ b/qt5/src/poppler-page.cc
-@@ -46,6 +46,7 @@
+@@ -47,6 +47,7 @@
#include <QtGui/QPainter>
#include <config.h>
@@ -77,7 +77,7 @@ index b48ee959..d2d52069 100644
#include <PDFDoc.h>
#include <Catalog.h>
#include <Form.h>
-@@ -59,6 +60,9 @@
+@@ -60,6 +61,9 @@
#include <SplashOutputDev.h>
#include <splash/SplashBitmap.h>
#endif
@@ -87,7 +87,7 @@ index b48ee959..d2d52069 100644
#include "poppler-private.h"
#include "poppler-page-transition-private.h"
-@@ -621,6 +625,70 @@ QImage Page::renderToImage(double xres, double yres, int x, int y, int w, int h,
+@@ -623,6 +627,70 @@ QImage Page::renderToImage(double xres, double yres, int x, int y, int w, int h,
img = tmpimg;
break;
}
@@ -148,7 +148,7 @@ index b48ee959..d2d52069 100644
+ false, x, y, w, h);
+
+ // Clean up
-+ output_dev->setCairo(NULL);
++ output_dev->setCairo(nullptr);
+ cairo_destroy(cairo);
+ cairo_surface_destroy(surface);
+ delete output_dev;
@@ -158,7 +158,7 @@ index b48ee959..d2d52069 100644
}
if (shouldAbortRenderCallback && shouldAbortRenderCallback(payload))
-@@ -643,6 +711,8 @@ bool Page::renderToPainter(QPainter* painter, double xres, double yres, int x, i
+@@ -645,6 +713,8 @@ bool Page::renderToPainter(QPainter* painter, double xres, double yres, int x, i
QImageDumpingArthurOutputDev arthur_output(painter, nullptr);
return renderToArthur(&arthur_output, painter, m_page, xres, yres, x, y, w, h, rotate, flags);
}
@@ -168,10 +168,10 @@ index b48ee959..d2d52069 100644
return false;
}
diff --git a/qt5/src/poppler-qt5.h b/qt5/src/poppler-qt5.h
-index b70644f7..f4b1ba71 100644
+index ed189701..2e8ca01f 100644
--- a/qt5/src/poppler-qt5.h
+++ b/qt5/src/poppler-qt5.h
-@@ -1054,7 +1054,8 @@ delete it;
+@@ -1061,7 +1061,8 @@ delete it;
*/
enum RenderBackend {
SplashBackend, ///< Splash backend
@@ -182,7 +182,7 @@ index b70644f7..f4b1ba71 100644
/**
diff --git a/qt5/tests/CMakeLists.txt b/qt5/tests/CMakeLists.txt
-index 1e67e6ec..9131568d 100644
+index af8de6ef..20df9f4b 100644
--- a/qt5/tests/CMakeLists.txt
+++ b/qt5/tests/CMakeLists.txt
@@ -11,6 +11,11 @@ include_directories(
@@ -198,5 +198,5 @@ index 1e67e6ec..9131568d 100644
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5Gui_EXECUTABLE_COMPILE_FLAGS}")
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5Xml_EXECUTABLE_COMPILE_FLAGS}")
--
-2.18.0
+2.19.1