summarylogtreecommitdiffstats
path: root/0001-Cairo-backend-added-to-Qt5-wrapper.patch
diff options
context:
space:
mode:
Diffstat (limited to '0001-Cairo-backend-added-to-Qt5-wrapper.patch')
-rw-r--r--0001-Cairo-backend-added-to-Qt5-wrapper.patch24
1 files changed, 12 insertions, 12 deletions
diff --git a/0001-Cairo-backend-added-to-Qt5-wrapper.patch b/0001-Cairo-backend-added-to-Qt5-wrapper.patch
index f7870de9181e..cc44d2786a24 100644
--- a/0001-Cairo-backend-added-to-Qt5-wrapper.patch
+++ b/0001-Cairo-backend-added-to-Qt5-wrapper.patch
@@ -1,4 +1,4 @@
-From 3ea09a476618ec9c2831449cb668463f47f09e55 Mon Sep 17 00:00:00 2001
+From c9507c38913711b9497b5db03df6ed0eb6627f2f Mon Sep 17 00:00:00 2001
From: Paul Gideon Dann <pdgiddie@gmail.com>
Date: Wed, 4 Apr 2018 16:36:56 +0100
Subject: [PATCH 1/3] Cairo backend added to Qt5 wrapper
@@ -12,10 +12,10 @@ Subject: [PATCH 1/3] Cairo backend added to Qt5 wrapper
5 files changed, 95 insertions(+), 1 deletion(-)
diff --git a/qt5/src/CMakeLists.txt b/qt5/src/CMakeLists.txt
-index 80f40fca..18059d7a 100644
+index ae055a12..8cc1f540 100644
--- a/qt5/src/CMakeLists.txt
+++ b/qt5/src/CMakeLists.txt
-@@ -8,6 +8,11 @@ include_directories(
+@@ -5,6 +5,11 @@ include_directories(
${CMAKE_CURRENT_BINARY_DIR}
)
@@ -27,7 +27,7 @@ index 80f40fca..18059d7a 100644
set(CMAKE_C_VISIBILITY_PRESET hidden)
set(CMAKE_CXX_VISIBILITY_PRESET hidden)
set(CMAKE_VISIBILITY_INLINES_HIDDEN 1)
-@@ -39,6 +44,13 @@ set(poppler_qt5_SRCS
+@@ -36,6 +41,13 @@ set(poppler_qt5_SRCS
QPainterOutputDev.cc
poppler-version.cpp
)
@@ -41,10 +41,10 @@ index 80f40fca..18059d7a 100644
add_library(poppler-qt5 ${poppler_qt5_SRCS})
set_target_properties(poppler-qt5 PROPERTIES VERSION 1.26.0 SOVERSION 1)
if(MINGW AND BUILD_SHARED_LIBS)
-@@ -46,6 +58,9 @@ if(MINGW AND BUILD_SHARED_LIBS)
+@@ -43,6 +55,9 @@ if(MINGW AND BUILD_SHARED_LIBS)
set_target_properties(poppler-qt5 PROPERTIES SUFFIX "-${POPPLER_QT5_SOVERSION}${CMAKE_SHARED_LIBRARY_SUFFIX}")
endif()
- target_link_libraries(poppler-qt5 poppler ${Qt5Core_LIBRARIES} ${Qt5Gui_LIBRARIES} ${Qt5Xml_LIBRARIES} ${FREETYPE_LIBRARIES})
+ target_link_libraries(poppler-qt5 poppler Qt5::Core Qt5::Gui Qt5::Xml ${FREETYPE_LIBRARIES})
+if (HAVE_CAIRO)
+ target_link_libraries(poppler-qt5 ${CAIRO_LIBRARIES})
+endif (HAVE_CAIRO)
@@ -182,11 +182,11 @@ index 6c167b65..f1672888 100644
/**
diff --git a/qt5/tests/CMakeLists.txt b/qt5/tests/CMakeLists.txt
-index b8b5a399..caee9525 100644
+index 82ef2139..56860c32 100644
--- a/qt5/tests/CMakeLists.txt
+++ b/qt5/tests/CMakeLists.txt
-@@ -11,6 +11,11 @@ include_directories(
- ${Qt5Widgets_INCLUDE_DIRS}
+@@ -6,6 +6,11 @@ include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
)
+if (HAVE_CAIRO)
@@ -194,9 +194,9 @@ index b8b5a399..caee9525 100644
+ add_definitions(${CAIRO_CFLAGS})
+endif (HAVE_CAIRO)
+
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5Core_EXECUTABLE_COMPILE_FLAGS}")
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5Gui_EXECUTABLE_COMPILE_FLAGS}")
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5Xml_EXECUTABLE_COMPILE_FLAGS}")
+ macro(QT5_ADD_SIMPLETEST exe source)
+ string(REPLACE "-" "" test_name ${exe})
+ set(${test_name}_SOURCES
--
2.29.2