summarylogtreecommitdiffstats
path: root/0001-Disable-deprecated-function-warnings-to-fix-build-wi.patch
diff options
context:
space:
mode:
Diffstat (limited to '0001-Disable-deprecated-function-warnings-to-fix-build-wi.patch')
-rw-r--r--0001-Disable-deprecated-function-warnings-to-fix-build-wi.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/0001-Disable-deprecated-function-warnings-to-fix-build-wi.patch b/0001-Disable-deprecated-function-warnings-to-fix-build-wi.patch
new file mode 100644
index 000000000000..b2c55ffd37de
--- /dev/null
+++ b/0001-Disable-deprecated-function-warnings-to-fix-build-wi.patch
@@ -0,0 +1,26 @@
+From 6c7238fcd0eca358686076d4db940d67a509e303 Mon Sep 17 00:00:00 2001
+From: Nicolas Iooss <nicolas.iooss@m4x.org>
+Date: Sat, 5 Dec 2020 17:24:51 +0100
+Subject: [PATCH 1/1] Disable deprecated function warnings to fix build with
+ Cython 0.29.21 and Python 3.9
+
+Fixes: https://github.com/SELinuxProject/setools/issues/54
+---
+ setup.py | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/setup.py b/setup.py
+index 457c83049ca5..0f717c5a1d0b 100644
+--- a/setup.py
++++ b/setup.py
+@@ -126,6 +126,7 @@ ext_py_mods = [Extension('setools.policyrep', ['setools/policyrep.pyx'],
+ '-Wno-unreachable-code',
+ '-Wno-implicit-fallthrough',
+ '-Wno-cast-function-type',
++ '-Wno-error=deprecated-declarations',
+ '-fno-exceptions'])]
+
+ installed_data = [('share/man/man1', glob.glob("man/*.1"))]
+--
+2.29.2
+