summarylogtreecommitdiffstats
path: root/0001-Don-t-create-a-symlink-if-there-is-no-SHAREDLIBVERSI.patch
diff options
context:
space:
mode:
Diffstat (limited to '0001-Don-t-create-a-symlink-if-there-is-no-SHAREDLIBVERSI.patch')
-rw-r--r--0001-Don-t-create-a-symlink-if-there-is-no-SHAREDLIBVERSI.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/0001-Don-t-create-a-symlink-if-there-is-no-SHAREDLIBVERSI.patch b/0001-Don-t-create-a-symlink-if-there-is-no-SHAREDLIBVERSI.patch
new file mode 100644
index 000000000000..78645e48b223
--- /dev/null
+++ b/0001-Don-t-create-a-symlink-if-there-is-no-SHAREDLIBVERSI.patch
@@ -0,0 +1,29 @@
+From fa772c2e3d41de4cdd587700f567b5aff59452bb Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Sebastian=20Dr=C3=B6ge?= <sebastian@centricular.com>
+Date: Wed, 24 Feb 2016 11:23:28 +0200
+Subject: [PATCH] Don't create a symlink if there is no $(SHAREDLIBVERSION)
+
+Otherwise we create a symlink with the same name as the target, which will
+create a symlink pointing to itself.
+---
+ Makefile.in | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index d9b2c4f..c0a67be 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -273,7 +273,9 @@ install:
+ if [ -f libsrtp.$(SHAREDLIBSUFFIX) ]; then \
+ $(INSTALL) -d $(DESTDIR)$(SHAREDLIB_DIR); \
+ cp libsrtp.$(SHAREDLIBSUFFIX) $(DESTDIR)$(SHAREDLIB_DIR)/; \
+- ln -sfn libsrtp.$(SHAREDLIBSUFFIX) $(DESTDIR)$(SHAREDLIB_DIR)/libsrtp.$(SHAREDLIBSUFFIXNOVER); \
++ if [ -n "$(SHAREDLIBVERSION)" ]; then \
++ ln -sfn libsrtp.$(SHAREDLIBSUFFIX) $(DESTDIR)$(SHAREDLIB_DIR)/libsrtp.$(SHAREDLIBSUFFIXNOVER); \
++ fi; \
+ fi
+ if [ "$(pkgconfig_DATA)" != "" ]; then \
+ $(INSTALL) -d $(DESTDIR)$(pkgconfigdir); \
+--
+2.7.0
+