summarylogtreecommitdiffstats
path: root/0001-Fix-build-on-Arch-Linux.patch
diff options
context:
space:
mode:
Diffstat (limited to '0001-Fix-build-on-Arch-Linux.patch')
-rw-r--r--0001-Fix-build-on-Arch-Linux.patch105
1 files changed, 105 insertions, 0 deletions
diff --git a/0001-Fix-build-on-Arch-Linux.patch b/0001-Fix-build-on-Arch-Linux.patch
new file mode 100644
index 000000000000..4b2c806a8211
--- /dev/null
+++ b/0001-Fix-build-on-Arch-Linux.patch
@@ -0,0 +1,105 @@
+From 4e425a5ce85c2ec78837153fe5a3ce55a59f8f57 Mon Sep 17 00:00:00 2001
+From: John Audia <graysky@archlinux.us>
+Date: Sat, 2 Jan 2021 07:01:05 -0500
+Subject: [PATCH] Fix build on Arch Linux
+
+Acknowledgment to squiddo for pointing these out.
+---
+ configure.ac | 2 +-
+ src/lxc/log.c | 4 ++--
+ src/lxc/lsm/apparmor.c | 2 +-
+ src/lxc/tools/arguments.c | 2 +-
+ src/lxc/tools/lxc_copy.c | 2 +-
+ src/lxc/utils.c | 2 +-
+ 6 files changed, 7 insertions(+), 7 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index f58487f5d..e1bcfab79 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -227,7 +227,7 @@ AM_CONDITIONAL([ENABLE_DOCBOOK], [test "x$db2xman" != "x"])
+ AM_CONDITIONAL([USE_DOCBOOK2X], [test "x$db2xman" != "xdocbook2man"])
+
+ if test "x$db2xman" = "xdocbook2man"; then
+- docdtd="\"-//Davenport//DTD DocBook V3.0//EN\""
++ docdtd="\"-//OASIS//DTD DocBook XML\" \"https://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd\""
+ else
+ docdtd="\"-//OASIS//DTD DocBook XML\" \"http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd\""
+ fi
+diff --git a/src/lxc/log.c b/src/lxc/log.c
+index 824c3f5fa..6c7574453 100644
+--- a/src/lxc/log.c
++++ b/src/lxc/log.c
+@@ -82,7 +82,7 @@ static int lxc_log_priority_to_syslog(int priority)
+ return LOG_NOTICE;
+ }
+
+-static const char *lxc_log_get_container_name()
++static const char *lxc_log_get_container_name(void)
+ {
+ #ifndef NO_LXC_CONF
+ if (current_config && !log_vmname)
+@@ -814,7 +814,7 @@ inline const char *lxc_log_get_prefix(void)
+ return log_prefix;
+ }
+
+-inline void lxc_log_options_no_override()
++inline void lxc_log_options_no_override(void)
+ {
+ lxc_quiet_specified = 1;
+ lxc_loglevel_specified = 1;
+diff --git a/src/lxc/lsm/apparmor.c b/src/lxc/lsm/apparmor.c
+index b09d47090..c4c6b03a6 100644
+--- a/src/lxc/lsm/apparmor.c
++++ b/src/lxc/lsm/apparmor.c
+@@ -593,7 +593,7 @@ static bool file_is_yes(const char *path)
+ return rd >= 4 && strncmp(buf, "yes\n", 4) == 0;
+ }
+
+-static bool apparmor_can_stack()
++static bool apparmor_can_stack(void)
+ {
+ int major, minor, scanned;
+ FILE *f;
+diff --git a/src/lxc/tools/arguments.c b/src/lxc/tools/arguments.c
+index dfed2a9ab..447031fc0 100644
+--- a/src/lxc/tools/arguments.c
++++ b/src/lxc/tools/arguments.c
+@@ -116,7 +116,7 @@ __noreturn static void print_usage_exit(const struct option longopts[],
+ exit(EXIT_SUCCESS);
+ }
+
+-__noreturn static void print_version_exit()
++__noreturn static void print_version_exit(void)
+ {
+ printf("%s\n", lxc_get_version());
+ exit(EXIT_SUCCESS);
+diff --git a/src/lxc/tools/lxc_copy.c b/src/lxc/tools/lxc_copy.c
+index db26094ad..c40692927 100644
+--- a/src/lxc/tools/lxc_copy.c
++++ b/src/lxc/tools/lxc_copy.c
+@@ -509,7 +509,7 @@ static int do_clone_task(struct lxc_container *c, enum task task, int flags,
+ return ret;
+ }
+
+-static void free_mnts()
++static void free_mnts(void)
+ {
+ unsigned int i;
+ struct mnts *n = NULL;
+diff --git a/src/lxc/utils.c b/src/lxc/utils.c
+index c4815d14c..d9f7f99aa 100644
+--- a/src/lxc/utils.c
++++ b/src/lxc/utils.c
+@@ -238,7 +238,7 @@ int mkdir_p(const char *dir, mode_t mode)
+ return 0;
+ }
+
+-char *get_rundir()
++char *get_rundir(void)
+ {
+ __do_free char *rundir = NULL;
+ char *static_rundir;
+--
+2.30.0
+