summarylogtreecommitdiffstats
path: root/0001-Linux-5.3-compat-Makefile-subdir-m-no-longer-support.patch
diff options
context:
space:
mode:
Diffstat (limited to '0001-Linux-5.3-compat-Makefile-subdir-m-no-longer-support.patch')
-rw-r--r--0001-Linux-5.3-compat-Makefile-subdir-m-no-longer-support.patch65
1 files changed, 65 insertions, 0 deletions
diff --git a/0001-Linux-5.3-compat-Makefile-subdir-m-no-longer-support.patch b/0001-Linux-5.3-compat-Makefile-subdir-m-no-longer-support.patch
new file mode 100644
index 000000000000..84ba2b55fa21
--- /dev/null
+++ b/0001-Linux-5.3-compat-Makefile-subdir-m-no-longer-support.patch
@@ -0,0 +1,65 @@
+From ac0fbbfdf3d686130985615184bc25470dcd8c13 Mon Sep 17 00:00:00 2001
+From: Dominic Pearson <dsp@technoanimal.net>
+Date: Tue, 20 Aug 2019 00:22:52 +0200
+Subject: [PATCH] Linux 5.3 compat: Makefile subdir-m no longer supported
+
+Uses obj-m instead, due to kernel changes.
+
+See LKML: Masahiro Yamada, Tue, 6 Aug 2019 19:03:23 +0900
+
+Reviewed-by: Brian Behlendorf <behlendorf1@llnl.gov>
+Reviewed-by: Tony Hutter <hutter2@llnl.gov>
+Signed-off-by: Dominic Pearson <dsp@technoanimal.net>
+Closes #9169
+(cherry picked from commit 70f67bdbbf5f0e8e099f19db7550cb6e444cb0f8)
+[Eli Schwartz: removed undesirable patch hunk for .gitignore, rebased
+without 8f12a4f8d2846ca668f8ad90d9ea5c19c8c0b78f conflicts]
+---
+ module/Makefile.in | 24 ++++++++++++------------
+ 1 file changed, 12 insertions(+), 12 deletions(-)
+
+diff --git a/module/Makefile.in b/module/Makefile.in
+index 935bd2663..168bc5a1b 100644
+--- a/module/Makefile.in
++++ b/module/Makefile.in
+@@ -1,11 +1,11 @@
+-subdir-m += avl
+-subdir-m += icp
+-subdir-m += lua
+-subdir-m += nvpair
+-subdir-m += spl
+-subdir-m += unicode
+-subdir-m += zcommon
+-subdir-m += zfs
++obj-m += avl/
++obj-m += icp/
++obj-m += lua/
++obj-m += nvpair/
++obj-m += spl/
++obj-m += unicode/
++obj-m += zcommon/
++obj-m += zfs/
+
+ INSTALL_MOD_DIR ?= extra
+
+@@ -60,13 +60,13 @@ modules_install:
+ modules_uninstall:
+ @# Uninstall the kernel modules
+ kmoddir=$(DESTDIR)$(INSTALL_MOD_PATH)/lib/modules/@LINUX_VERSION@
+- list='$(subdir-m)'; for subdir in $$list; do \
+- $(RM) -R $$kmoddir/$(INSTALL_MOD_DIR)/$$subdir; \
++ list='$(obj-m)'; for objdir in $$list; do \
++ $(RM) -R $$kmoddir/$(INSTALL_MOD_DIR)/$$objdir; \
+ done
+
+ distdir:
+- list='$(subdir-m)'; for subdir in $$list; do \
+- (cd @top_srcdir@/module && find $$subdir -name '*.c' -o -name '*.h' -o -name '*.S' |\
++ list='$(obj-m)'; for objdir in $$list; do \
++ (cd @top_srcdir@/module && find $$objdir -name '*.c' -o -name '*.h' -o -name '*.S' |\
+ xargs cp --parents -t $$distdir); \
+ done
+
+--
+2.23.0
+