summarylogtreecommitdiffstats
path: root/0001-Makefile-DESTDIR-support.patch
diff options
context:
space:
mode:
Diffstat (limited to '0001-Makefile-DESTDIR-support.patch')
-rw-r--r--0001-Makefile-DESTDIR-support.patch18
1 files changed, 9 insertions, 9 deletions
diff --git a/0001-Makefile-DESTDIR-support.patch b/0001-Makefile-DESTDIR-support.patch
index f7ff7bae7772..a6aed3a81730 100644
--- a/0001-Makefile-DESTDIR-support.patch
+++ b/0001-Makefile-DESTDIR-support.patch
@@ -1,4 +1,4 @@
-From 3f3383518ba864092ea67f87295908bc2d96eb07 Mon Sep 17 00:00:00 2001
+From 8f1dc9498cb4f7969d5700904d4b19d8517c9679 Mon Sep 17 00:00:00 2001
From: Ivan Shapovalov <intelfx@intelfx.name>
Date: Sat, 22 Oct 2016 12:35:14 +0300
Subject: [PATCH 1/5] Makefile: DESTDIR support
@@ -8,10 +8,10 @@ Subject: [PATCH 1/5] Makefile: DESTDIR support
1 file changed, 14 insertions(+), 13 deletions(-)
diff --git a/Makefile b/Makefile
-index 5d97412..ae73d56 100644
+index 051dc66..8079ddf 100644
--- a/Makefile
+++ b/Makefile
-@@ -38,7 +38,7 @@ INSTALL=install
+@@ -39,7 +39,7 @@ INSTALL=install
ROOT=root
# Pathnames for referenced packages...
@@ -20,7 +20,7 @@ index 5d97412..ae73d56 100644
# User ID's
LPuid=-oroot
-@@ -248,8 +248,9 @@ FILES = \
+@@ -251,8 +251,9 @@ FILES = \
# CUPS vars
CUPS_SERVERBIN := $(DESTDIR)$(shell cups-config --serverbin 2>/dev/null)
@@ -32,7 +32,7 @@ index 5d97412..ae73d56 100644
# hpclj2600n-0.icm km2430_0.icm km2430_1.icm km2430_2.icm samclp300-0.icm
# sihp1000.img sihp1005.img sihp1020.img sihp1018.img
-@@ -661,7 +662,7 @@ install-prog:
+@@ -676,7 +677,7 @@ install-prog:
$(INSTALL) -c $(PROGS) $(SHELLS) $(BIN)/
if [ "$(BINPROGS)" != "" ]; then \
$(INSTALL) -d $(UDEVBIN); \
@@ -41,7 +41,7 @@ index 5d97412..ae73d56 100644
fi
#
# Install gamma correction files. These are just templates,
-@@ -715,10 +716,10 @@ install-foo:
+@@ -730,10 +731,10 @@ install-foo:
#
# Clear foomatic cache and rebuild database if needed
#
@@ -56,7 +56,7 @@ index 5d97412..ae73d56 100644
foomatic-combo-xml -O >overview.xml; \
fi
-@@ -848,7 +849,7 @@ install-extra:
+@@ -863,7 +864,7 @@ install-extra:
done
MODEL=$(PREFIX)/share/cups/model
@@ -65,7 +65,7 @@ index 5d97412..ae73d56 100644
MACMODEL=/Library/Printers/PPDs/Contents/Resources
PPD=$(PREFIX)/share/ppd
VARPPD=/var/lp/ppd
-@@ -908,9 +909,9 @@ install-ppd:
+@@ -923,9 +924,9 @@ install-ppd:
done; \
fi
@@ -78,7 +78,7 @@ index 5d97412..ae73d56 100644
install-desktop:
#
-@@ -934,7 +935,7 @@ install-gui:
+@@ -949,7 +950,7 @@ install-gui:
$(INSTALL) -c -m 755 hplj10xx_gui.tcl $(SHAREZJS)