summarylogtreecommitdiffstats
path: root/0001-Remove-mupdf-linking-detection.patch
diff options
context:
space:
mode:
Diffstat (limited to '0001-Remove-mupdf-linking-detection.patch')
-rw-r--r--0001-Remove-mupdf-linking-detection.patch76
1 files changed, 76 insertions, 0 deletions
diff --git a/0001-Remove-mupdf-linking-detection.patch b/0001-Remove-mupdf-linking-detection.patch
new file mode 100644
index 000000000000..34349d785197
--- /dev/null
+++ b/0001-Remove-mupdf-linking-detection.patch
@@ -0,0 +1,76 @@
+From 97259584339d5bdff677c7f6a076b996bc64cbb1 Mon Sep 17 00:00:00 2001
+From: a821 <a821@nospam.mail.de>
+Date: Sat, 14 Jan 2023 17:52:03 +0100
+Subject: [PATCH] Remove mupdf linking detection
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Patch adapted from official PKGBUILD by Johannes Löthberg.
+---
+ meson.build | 40 ++++++++++++++--------------------------
+ 1 file changed, 14 insertions(+), 26 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index c7b5a8b..9fecc62 100644
+--- a/meson.build
++++ b/meson.build
+@@ -19,8 +19,6 @@ zathura = dependency('zathura', version: '>=0.5.2')
+ girara = dependency('girara-gtk3')
+ glib = dependency('glib-2.0')
+ cairo = dependency('cairo')
+-mupdf = dependency('mupdf', required: false)
+-mupdfthird = cc.find_library('mupdf-third')
+
+ build_dependencies = [
+ zathura,
+@@ -29,32 +27,22 @@ build_dependencies = [
+ cairo,
+ ]
+
+-if not mupdf.found()
+- # normal build of mupdf
+- mupdf = cc.find_library('mupdf')
+- build_dependencies += [mupdf, mupdfthird]
+-else
+- # build from Debian's libmupdf-dev
+- build_dependencies += [mupdf, mupdfthird]
++mupdf = cc.find_library('mupdf')
++mupdfthird = cc.find_library('mupdf-third')
+
+- libjpeg = dependency('libjpeg')
+- libjbig2dec = cc.find_library('jbig2dec')
+- libopenjp2 = dependency('libopenjp2')
+- gumbo = dependency('gumbo')
+- tesseract = dependency('tesseract')
+- leptonica = dependency('lept')
+- mujs = dependency('mujs')
++libjpeg = dependency('libjpeg')
++libjbig2dec = cc.find_library('jbig2dec')
++libopenjp2 = dependency('libopenjp2')
++gumbo = dependency('gumbo')
+
+- build_dependencies += [
+- libjpeg,
+- libjbig2dec,
+- libopenjp2,
+- gumbo,
+- tesseract,
+- leptonica,
+- mujs
+- ]
+-endif
++build_dependencies += [
++ mupdf,
++ mupdfthird,
++ libjpeg,
++ libjbig2dec,
++ libopenjp2,
++ gumbo,
++]
+
+ if get_option('plugindir') == ''
+ plugindir = zathura.get_variable(pkgconfig: 'plugindir')
+--
+2.39.0
+