summarylogtreecommitdiffstats
path: root/0001-Revert-elf-Correct-absolute-SHN_ABS-symbol-run-time-.patch
diff options
context:
space:
mode:
Diffstat (limited to '0001-Revert-elf-Correct-absolute-SHN_ABS-symbol-run-time-.patch')
-rw-r--r--0001-Revert-elf-Correct-absolute-SHN_ABS-symbol-run-time-.patch24
1 files changed, 12 insertions, 12 deletions
diff --git a/0001-Revert-elf-Correct-absolute-SHN_ABS-symbol-run-time-.patch b/0001-Revert-elf-Correct-absolute-SHN_ABS-symbol-run-time-.patch
index 780058f84467..7ccfbaec704a 100644
--- a/0001-Revert-elf-Correct-absolute-SHN_ABS-symbol-run-time-.patch
+++ b/0001-Revert-elf-Correct-absolute-SHN_ABS-symbol-run-time-.patch
@@ -1,4 +1,4 @@
-From e4d9bb4a08f3ad518f0f54163f3043ca72c593e3 Mon Sep 17 00:00:00 2001
+From e0cff4a2cace32698e9531bbdbd6e5ce59b5756a Mon Sep 17 00:00:00 2001
From: Eli Schwartz <eschwartz@archlinux.org>
Date: Fri, 28 Sep 2018 05:19:46 +0000
Subject: [PATCH] Revert "elf: Correct absolute (SHN_ABS) symbol run-time
@@ -18,7 +18,7 @@ This reverts commit e7feec374c635b6a29d65c39ae5e1855528fed39.
delete mode 100644 elf/tst-absolute-sym.c
diff --git a/elf/Makefile b/elf/Makefile
-index d72e7b67f6..91fd26973d 100644
+index 9cf5cd8dfd..1b144d67e2 100644
--- a/elf/Makefile
+++ b/elf/Makefile
@@ -186,7 +186,7 @@ tests += restest1 preloadtest loadfail multiload origtest resolvfail \
@@ -30,7 +30,7 @@ index d72e7b67f6..91fd26973d 100644
tst-unwind-ctor tst-unwind-main
# reldep9
tests-internal += loadtest unload unload2 circleload1 \
-@@ -273,7 +273,7 @@ modules-names = testobj1 testobj2 testobj3 testobj4 testobj5 testobj6 \
+@@ -274,7 +274,7 @@ modules-names = testobj1 testobj2 testobj3 testobj4 testobj5 testobj6 \
tst-audit12mod1 tst-audit12mod2 tst-audit12mod3 tst-auditmod12 \
tst-latepthreadmod $(tst-tls-many-dynamic-modules) \
tst-nodelete-dlclose-dso tst-nodelete-dlclose-plugin \
@@ -40,7 +40,7 @@ index d72e7b67f6..91fd26973d 100644
# Most modules build with _ISOMAC defined, but those filtered out
# depend on internal headers.
diff --git a/elf/dl-addr.c b/elf/dl-addr.c
-index e6c7d02094..2250617a73 100644
+index 9d285d76a7..0dd7d1dde9 100644
--- a/elf/dl-addr.c
+++ b/elf/dl-addr.c
@@ -59,7 +59,6 @@ determine_info (const ElfW(Addr) addr, struct link_map *match, Dl_info *info,
@@ -61,12 +61,12 @@ index e6c7d02094..2250617a73 100644
matchsym = (ElfW(Sym) *) symtab;
diff --git a/elf/tst-absolute-sym-lib.c b/elf/tst-absolute-sym-lib.c
deleted file mode 100644
-index 912cb0048a..0000000000
+index e0becab58e..0000000000
--- a/elf/tst-absolute-sym-lib.c
+++ /dev/null
@@ -1,25 +0,0 @@
-/* BZ #19818 absolute symbol calculation shared module.
-- Copyright (C) 2018 Free Software Foundation, Inc.
+- Copyright (C) 2018-2019 Free Software Foundation, Inc.
- This file is part of the GNU C Library.
-
- The GNU C Library is free software; you can redistribute it and/or
@@ -92,12 +92,12 @@ index 912cb0048a..0000000000
-}
diff --git a/elf/tst-absolute-sym-lib.lds b/elf/tst-absolute-sym-lib.lds
deleted file mode 100644
-index d4a4128514..0000000000
+index fcb990116a..0000000000
--- a/elf/tst-absolute-sym-lib.lds
+++ /dev/null
@@ -1,19 +0,0 @@
-/* BZ #19818 absolute symbol calculation linker script.
-- Copyright (C) 2018 Free Software Foundation, Inc.
+- Copyright (C) 2018-2019 Free Software Foundation, Inc.
- This file is part of the GNU C Library.
-
- The GNU C Library is free software; you can redistribute it and/or
@@ -117,12 +117,12 @@ index d4a4128514..0000000000
-"absolute" = 0x55aa;
diff --git a/elf/tst-absolute-sym.c b/elf/tst-absolute-sym.c
deleted file mode 100644
-index 111491d159..0000000000
+index c641f7ecdf..0000000000
--- a/elf/tst-absolute-sym.c
+++ /dev/null
@@ -1,38 +0,0 @@
-/* BZ #19818 absolute symbol calculation main executable.
-- Copyright (C) 2018 Free Software Foundation, Inc.
+- Copyright (C) 2018-2019 Free Software Foundation, Inc.
- This file is part of the GNU C Library.
-
- The GNU C Library is free software; you can redistribute it and/or
@@ -160,7 +160,7 @@ index 111491d159..0000000000
-
-#include <support/test-driver.c>
diff --git a/sysdeps/generic/ldsodefs.h b/sysdeps/generic/ldsodefs.h
-index 95dc87519b..3cac4fa362 100644
+index 37cab6f06b..eb01538256 100644
--- a/sysdeps/generic/ldsodefs.h
+++ b/sysdeps/generic/ldsodefs.h
@@ -72,8 +72,7 @@ typedef struct link_map *lookup_t;
@@ -174,5 +174,5 @@ index 95dc87519b..3cac4fa362 100644
/* On some architectures a pointer to a function is not just a pointer
to the actual code of the function but rather an architecture
--
-2.19.1
+2.20.1