summarylogtreecommitdiffstats
path: root/0001-Set-correct-library-names.patch
diff options
context:
space:
mode:
Diffstat (limited to '0001-Set-correct-library-names.patch')
-rw-r--r--0001-Set-correct-library-names.patch38
1 files changed, 0 insertions, 38 deletions
diff --git a/0001-Set-correct-library-names.patch b/0001-Set-correct-library-names.patch
deleted file mode 100644
index 261fa0b82c98..000000000000
--- a/0001-Set-correct-library-names.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From 8735d30e13067146ba6e1968b491b4654fdb19f7 Mon Sep 17 00:00:00 2001
-From: KokaKiwi <kokakiwi+git@kokakiwi.net>
-Date: Sun, 19 Sep 2021 15:10:13 +0200
-Subject: [PATCH] Set correct library names
-
----
- CMakeLists.txt | 7 +++++--
- 1 file changed, 5 insertions(+), 2 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 4aab3a3..5178b35 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -34,6 +34,7 @@ else()
- endif()
- if (NOT USE_SYSTEM_YARA)
- add_subdirectory(external/yara)
-+ set(YARA_LIBRARIES libyara)
- else()
- find_package(PkgConfig REQUIRED)
- pkg_check_modules(YARA REQUIRED IMPORTED_TARGET yara)
-@@ -103,9 +104,11 @@ set_target_properties(imhex PROPERTIES CXX_VISIBILITY_PRESET hidden)
- target_link_directories(imhex PRIVATE ${CAPSTONE_LIBRARY_DIRS} ${MAGIC_LIBRARY_DIRS})
-
- if (WIN32)
-- target_link_libraries(imhex ${CMAKE_DL_LIBS} capstone LLVMDemangle libimhex ${Python_LIBRARIES} wsock32 ws2_32 libyara Dwmapi.lib dl)
-+ target_link_libraries(imhex ${CMAKE_DL_LIBS} capstone LLVMDemangle libimhex ${Python_LIBRARIES} wsock32 ws2_32
-+ ${YARA_LIBRARIES} Dwmapi.lib dl)
- else ()
-- target_link_libraries(imhex ${CMAKE_DL_LIBS} capstone LLVMDemangle libimhex ${Python_LIBRARIES} dl pthread libyara)
-+ target_link_libraries(imhex ${CMAKE_DL_LIBS} capstone LLVMDemangle libimhex ${Python_LIBRARIES} dl pthread
-+ ${YARA_LIBRARIES})
- endif ()
-
- createPackage()
---
-2.33.0
-