summarylogtreecommitdiffstats
path: root/0001-fix-DirectXMath-detection.patch
diff options
context:
space:
mode:
Diffstat (limited to '0001-fix-DirectXMath-detection.patch')
-rw-r--r--0001-fix-DirectXMath-detection.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/0001-fix-DirectXMath-detection.patch b/0001-fix-DirectXMath-detection.patch
new file mode 100644
index 000000000000..65347fdf154b
--- /dev/null
+++ b/0001-fix-DirectXMath-detection.patch
@@ -0,0 +1,25 @@
+From 09cedd4384bb2e9446272c188df1b5cad4d28378 Mon Sep 17 00:00:00 2001
+From: Nicola Murino <nicola.murino@gmail.com>
+Date: Thu, 28 Mar 2024 14:21:57 +0100
+Subject: [PATCH] fix DirectXMath detection
+
+---
+ gst-libs/gst/d3d11/meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/gst-libs/gst/d3d11/meson.build b/gst-libs/gst/d3d11/meson.build
+index 5abb136..e949be2 100644
+--- a/gst-libs/gst/d3d11/meson.build
++++ b/gst-libs/gst/d3d11/meson.build
+@@ -196,7 +196,7 @@ have_dx_math = cxx.compiles('''
+ name: 'DirectXMath support in Windows SDK')
+
+ if not have_dx_math
+- directxmath_dep = dependency('directxmath',
++ directxmath_dep = dependency('DirectXMath',
+ allow_fallback: true,
+ required: get_option('d3d11-math'))
+ extra_deps += [directxmath_dep]
+--
+2.44.0
+