summarylogtreecommitdiffstats
path: root/0001-fix_cmake_module_install_path.patch
diff options
context:
space:
mode:
Diffstat (limited to '0001-fix_cmake_module_install_path.patch')
-rw-r--r--0001-fix_cmake_module_install_path.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/0001-fix_cmake_module_install_path.patch b/0001-fix_cmake_module_install_path.patch
new file mode 100644
index 000000000000..f8bbaa021ae6
--- /dev/null
+++ b/0001-fix_cmake_module_install_path.patch
@@ -0,0 +1,12 @@
+--- CMakeLists.txt.orig 2015-01-12 21:34:37.788280159 +0100
++++ CMakeLists.txt 2015-01-12 21:36:44.646681413 +0100
+@@ -242,7 +242,8 @@
+ install(FILES license.txt DESTINATION ${INSTALL_MISC_DIR})
+ install(FILES readme.txt DESTINATION ${INSTALL_MISC_DIR})
+ if(NOT SFML_OS_ANDROID)
+- install(FILES cmake/Modules/FindSFML.cmake DESTINATION ${INSTALL_MISC_DIR}/cmake/Modules)
++ set(CM_VER ${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION})
++ install(FILES cmake/Modules/FindSFML.cmake DESTINATION share/cmake-${CM_VER}/Modules)
+ endif()
+
+ # install 3rd-party libraries and tools