summarylogtreecommitdiffstats
path: root/0001-makepkg-Remove-external-stuff.patch
diff options
context:
space:
mode:
Diffstat (limited to '0001-makepkg-Remove-external-stuff.patch')
-rw-r--r--0001-makepkg-Remove-external-stuff.patch27
1 files changed, 18 insertions, 9 deletions
diff --git a/0001-makepkg-Remove-external-stuff.patch b/0001-makepkg-Remove-external-stuff.patch
index 58442ecd8a40..e6aa0bead52b 100644
--- a/0001-makepkg-Remove-external-stuff.patch
+++ b/0001-makepkg-Remove-external-stuff.patch
@@ -1,18 +1,18 @@
-From 9bbc271de0828bdcada005030f59023b79db4b03 Mon Sep 17 00:00:00 2001
+From 19da13e41a4cc5cdd0d28ed22f8ca0083b01ffd0 Mon Sep 17 00:00:00 2001
From: KokaKiwi <kokakiwi+git@kokakiwi.net>
Date: Thu, 3 Mar 2022 19:58:41 +0100
Subject: [PATCH 1/3] makepkg: Remove external stuff
---
CMakeLists.txt | 1 -
- cmake/build_helpers.cmake | 31 -------------------------------
- 2 files changed, 32 deletions(-)
+ cmake/build_helpers.cmake | 39 +--------------------------------------
+ 2 files changed, 1 insertion(+), 39 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 47ab66fa..7733b02c 100644
+index 7cba0c6b..b4088cae 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -14,7 +14,6 @@ option(IMHEX_OFFLINE_BUILD "Enable offline build" OFF)
+@@ -15,7 +15,6 @@ option(IMHEX_PATTERNS_PULL_MASTER "Download latest files from master branch of t
# Make sure project is configured correctly
setDefaultBuiltTypeIfUnset()
@@ -21,18 +21,21 @@ index 47ab66fa..7733b02c 100644
# List plugin names here. Project name must match folder name
set(PLUGINS
diff --git a/cmake/build_helpers.cmake b/cmake/build_helpers.cmake
-index 366aba89..33552e58 100644
+index 8a40a609..5aff088f 100644
--- a/cmake/build_helpers.cmake
+++ b/cmake/build_helpers.cmake
-@@ -226,7 +226,6 @@ macro(createPackage)
+@@ -226,9 +226,8 @@ macro(createPackage)
install(FILES ${CMAKE_SOURCE_DIR}/dist/imhex.desktop DESTINATION ${CMAKE_INSTALL_PREFIX}/share/applications)
install(FILES ${CMAKE_SOURCE_DIR}/resources/icon.png DESTINATION ${CMAKE_INSTALL_PREFIX}/share/pixmaps RENAME imhex.png)
install(FILES "$<TARGET_FILE:libimhex>" DESTINATION "${CMAKE_INSTALL_LIBDIR}")
- downloadImHexPatternsFiles("./share/imhex")
endif()
-
+-
++
if (CREATE_BUNDLE)
-@@ -276,33 +275,3 @@ macro(setDefaultBuiltTypeIfUnset)
+ include(PostprocessBundle)
+
+@@ -276,39 +275,3 @@ macro(setDefaultBuiltTypeIfUnset)
set_property(CACHE CMAKE_BUILD_TYPE PROPERTY STRINGS "Debug" "Release")
endif()
endmacro()
@@ -51,6 +54,12 @@ index 366aba89..33552e58 100644
-
-function(downloadImHexPatternsFiles dest)
- if (NOT IMHEX_OFFLINE_BUILD)
+- if (IMHEX_PATTERNS_PULL_MASTER)
+- set(PATTERNS_BRANCH master)
+- else ()
+- set(PATTERNS_BRANCH ImHex-v${IMHEX_VERSION})
+- endif ()
+-
- FetchContent_Declare(
- imhex_patterns
- GIT_REPOSITORY https://github.com/WerWolv/ImHex-Patterns.git