summarylogtreecommitdiffstats
path: root/0001-plugin.patch
diff options
context:
space:
mode:
Diffstat (limited to '0001-plugin.patch')
-rw-r--r--0001-plugin.patch46
1 files changed, 0 insertions, 46 deletions
diff --git a/0001-plugin.patch b/0001-plugin.patch
deleted file mode 100644
index 803c7c5510b1..000000000000
--- a/0001-plugin.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-diff --git a/configure.ac b/configure.ac
-index f4073d0..5fe652e 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -301,13 +301,12 @@ AC_ARG_WITH(
- [with_crypto_library="openssl"]
- )
-
--AC_ARG_WITH(
-- [plugindir],
-- [AS_HELP_STRING([--with-plugindir], [plugin directory @<:@default=LIBDIR/openvpn@:>@])],
-- ,
-- [with_plugindir="\$(libdir)/openvpn/plugins"]
--)
--
-+AC_ARG_VAR([PLUGINDIR], [Path of plug-in directory @<:@default=LIBDIR/openvpn/plugins@:>@])
-+if test -n "${PLUGINDIR}"; then
-+ plugindir="${PLUGINDIR}"
-+else
-+ plugindir="\${libdir}/openvpn/plugins"
-+fi
-
- AC_DEFINE_UNQUOTED([TARGET_ALIAS], ["${host}"], [A string representing our host])
- case "$host" in
-@@ -1245,7 +1244,6 @@ AM_CONDITIONAL([ENABLE_PLUGIN_AUTH_PAM], [test "${enable_plugin_auth_pam}" = "ye
- AM_CONDITIONAL([ENABLE_PLUGIN_DOWN_ROOT], [test "${enable_plugin_down_root}" = "yes"])
- AM_CONDITIONAL([ENABLE_CRYPTO], [test "${enable_crypto}" = "yes"])
-
--plugindir="${with_plugindir}"
- sampledir="\$(docdir)/sample"
- AC_SUBST([plugindir])
- AC_SUBST([sampledir])
-diff --git a/src/openvpn/Makefile.am b/src/openvpn/Makefile.am
-index 4c18449..188834a 100644
---- a/src/openvpn/Makefile.am
-+++ b/src/openvpn/Makefile.am
-@@ -27,7 +27,8 @@ AM_CFLAGS = \
- $(OPTIONAL_CRYPTO_CFLAGS) \
- $(OPTIONAL_LZO_CFLAGS) \
- $(OPTIONAL_LZ4_CFLAGS) \
-- $(OPTIONAL_PKCS11_HELPER_CFLAGS)
-+ $(OPTIONAL_PKCS11_HELPER_CFLAGS) \
-+ -DPLUGIN_LIBDIR=\"${plugindir}\"
- if WIN32
- # we want unicode entry point but not the macro
- AM_CFLAGS += -municode -UUNICODE