summarylogtreecommitdiffstats
path: root/0001_add_option_to_use_system_yaml_cpp.patch
diff options
context:
space:
mode:
Diffstat (limited to '0001_add_option_to_use_system_yaml_cpp.patch')
-rw-r--r--0001_add_option_to_use_system_yaml_cpp.patch36
1 files changed, 0 insertions, 36 deletions
diff --git a/0001_add_option_to_use_system_yaml_cpp.patch b/0001_add_option_to_use_system_yaml_cpp.patch
deleted file mode 100644
index db2ec11619ce..000000000000
--- a/0001_add_option_to_use_system_yaml_cpp.patch
+++ /dev/null
@@ -1,36 +0,0 @@
---- ashuffle-3.13.0/meson.build.orig 2021-12-24 03:14:57.007444254 +0100
-+++ ashuffle-3.13.0/meson.build 2021-12-24 03:18:28.724398808 +0100
-@@ -80,9 +80,14 @@
- endforeach
- endif
-
--yaml_cpp = cmake.subproject('yaml-cpp', cmake_options: cmake_common_args + [
-- '-DYAML_BUILD_SHARED_LIBS=OFF',
--])
-+if not get_option('unsupported_use_system_yaml_cpp')
-+ yaml_sub = cmake.subproject('yaml-cpp', cmake_options: cmake_common_args + [
-+ '-DYAML_BUILD_SHARED_LIBS=OFF',
-+ ])
-+ yaml_cpp = yaml_sub.dependency('yaml-cpp')
-+else
-+ yaml_cpp = dependency('yaml-cpp')
-+endif
-
- libmpdclient = dependency('libmpdclient')
-
-@@ -118,7 +123,7 @@
- sources,
- include_directories: src_inc,
- dependencies: absl_deps + [
-- yaml_cpp.dependency('yaml-cpp'),
-+ yaml_cpp,
- ],
- )
-
---- ashuffle-3.13.0/meson_options.txt.orig 2021-12-24 03:18:53.958163738 +0100
-+++ ashuffle-3.13.0/meson_options.txt 2021-12-24 03:19:21.361965784 +0100
-@@ -1,3 +1,4 @@
- option('tests', type : 'feature', value : 'disabled')
- option('unsupported_use_system_absl', type : 'boolean', value : 'false')
- option('unsupported_use_system_gtest', type : 'boolean', value : 'false')
-+option('unsupported_use_system_yaml_cpp', type : 'boolean', value : 'false')