summarylogtreecommitdiffstats
path: root/0002-ZEN-Add-VHBA-driver.patch
diff options
context:
space:
mode:
Diffstat (limited to '0002-ZEN-Add-VHBA-driver.patch')
-rw-r--r--0002-ZEN-Add-VHBA-driver.patch13
1 files changed, 5 insertions, 8 deletions
diff --git a/0002-ZEN-Add-VHBA-driver.patch b/0002-ZEN-Add-VHBA-driver.patch
index 71f1b9d1a755..23a34124a9f3 100644
--- a/0002-ZEN-Add-VHBA-driver.patch
+++ b/0002-ZEN-Add-VHBA-driver.patch
@@ -17,7 +17,7 @@ tag vhba-module-20211218
create mode 100644 drivers/scsi/vhba/vhba.c
diff --git a/drivers/scsi/Kconfig b/drivers/scsi/Kconfig
-index 6e3a04107bb6..78de7aecd852 100644
+index 6e3a04107bb657a83e5dc31758b6b343b3b817df..78de7aecd8528d658575f19596341a548a765bb8 100644
--- a/drivers/scsi/Kconfig
+++ b/drivers/scsi/Kconfig
@@ -1535,4 +1535,6 @@ endif # SCSI_LOWLEVEL
@@ -28,7 +28,7 @@ index 6e3a04107bb6..78de7aecd852 100644
+
endmenu
diff --git a/drivers/scsi/Makefile b/drivers/scsi/Makefile
-index 19814c26c908..e65448e9a8bc 100644
+index 19814c26c9084bdf086ef363e07d9b0d57a4ba71..e65448e9a8bcfe58377b9e2d3664dfad18f1dc50 100644
--- a/drivers/scsi/Makefile
+++ b/drivers/scsi/Makefile
@@ -153,6 +153,7 @@ obj-$(CONFIG_CHR_DEV_SCH) += ch.o
@@ -41,7 +41,7 @@ index 19814c26c908..e65448e9a8bc 100644
obj-$(CONFIG_SCSI_DEBUG) += scsi_debug.o
diff --git a/drivers/scsi/vhba/Kconfig b/drivers/scsi/vhba/Kconfig
new file mode 100644
-index 000000000000..e70a381fe3df
+index 0000000000000000000000000000000000000000..e70a381fe3dff807a4bfc6991aa257c345a289d9
--- /dev/null
+++ b/drivers/scsi/vhba/Kconfig
@@ -0,0 +1,9 @@
@@ -56,7 +56,7 @@ index 000000000000..e70a381fe3df
+ will be called vhba.
diff --git a/drivers/scsi/vhba/Makefile b/drivers/scsi/vhba/Makefile
new file mode 100644
-index 000000000000..ad8b7c6442af
+index 0000000000000000000000000000000000000000..ad8b7c6442af0757fc052e9d373d91e815059afb
--- /dev/null
+++ b/drivers/scsi/vhba/Makefile
@@ -0,0 +1,4 @@
@@ -66,7 +66,7 @@ index 000000000000..ad8b7c6442af
+ccflags-y := -DVHBA_VERSION=\"$(VHBA_VERSION)\" -Werror
diff --git a/drivers/scsi/vhba/vhba.c b/drivers/scsi/vhba/vhba.c
new file mode 100644
-index 000000000000..676af31c33ad
+index 0000000000000000000000000000000000000000..676af31c33ad9518ca7ae4db40bf1b5102798f50
--- /dev/null
+++ b/drivers/scsi/vhba/vhba.c
@@ -0,0 +1,1124 @@
@@ -1194,6 +1194,3 @@ index 000000000000..676af31c33ad
+module_init(vhba_init);
+module_exit(vhba_exit);
+
---
-2.35.1
-