summarylogtreecommitdiffstats
path: root/0002-cmake-no-exe.patch
diff options
context:
space:
mode:
Diffstat (limited to '0002-cmake-no-exe.patch')
-rw-r--r--0002-cmake-no-exe.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/0002-cmake-no-exe.patch b/0002-cmake-no-exe.patch
new file mode 100644
index 000000000000..e436c529b5af
--- /dev/null
+++ b/0002-cmake-no-exe.patch
@@ -0,0 +1,23 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index a2420f1..00ed7fe 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -189,18 +189,9 @@ if(BROTLI_PARENT_DIRECTORY)
+ set(BROTLI_LIBRARIES "${BROTLI_LIBRARIES}" PARENT_SCOPE)
+ endif()
+
+-# Build the brotli executable
+-add_executable(brotli ${BROTLI_CLI_C})
+-target_link_libraries(brotli ${BROTLI_LIBRARIES_CORE})
+-
+ # Installation
+ if(NOT BROTLI_EMSCRIPTEN)
+ if(NOT BROTLI_BUNDLED_MODE)
+- install(
+- TARGETS brotli
+- RUNTIME DESTINATION "${CMAKE_INSTALL_BINDIR}"
+- )
+-
+ install(
+ TARGETS ${BROTLI_LIBRARIES_CORE}
+ ARCHIVE DESTINATION "${CMAKE_INSTALL_LIBDIR}"