summarylogtreecommitdiffstats
path: root/0002-cmake-use-native-gtest.patch
diff options
context:
space:
mode:
Diffstat (limited to '0002-cmake-use-native-gtest.patch')
-rw-r--r--0002-cmake-use-native-gtest.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/0002-cmake-use-native-gtest.patch b/0002-cmake-use-native-gtest.patch
new file mode 100644
index 000000000000..a4e5901e4fa6
--- /dev/null
+++ b/0002-cmake-use-native-gtest.patch
@@ -0,0 +1,25 @@
+From e9d7442de4f0f52ce19629ccfe7ef036030f9669 Mon Sep 17 00:00:00 2001
+From: Xiretza <xiretza@xiretza.xyz>
+Date: Sat, 4 Jun 2022 11:22:15 +0200
+Subject: [PATCH 2/7] cmake: use native gtest
+
+---
+ src/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 94783a6..caf428a 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -63,7 +63,7 @@ set(ANTLR_EXECUTABLE ${CMAKE_CURRENT_SOURCE_DIR}/../third_party/antlr4_lib/antlr
+ find_package(ANTLR REQUIRED)
+
+ # Unit testing library
+-add_subdirectory(${CMAKE_CURRENT_SOURCE_DIR}/../third_party/googletest EXCLUDE_FROM_ALL googletest)
++find_package(GTest REQUIRED)
+
+ # Lexer and parser targets
+ antlr_target(FasmLexer antlr/FasmLexer.g4 LEXER
+--
+2.36.1
+