summarylogtreecommitdiffstats
path: root/0002-nghttp2-static.patch
diff options
context:
space:
mode:
Diffstat (limited to '0002-nghttp2-static.patch')
-rw-r--r--0002-nghttp2-static.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/0002-nghttp2-static.patch b/0002-nghttp2-static.patch
new file mode 100644
index 000000000000..24a53bdbada8
--- /dev/null
+++ b/0002-nghttp2-static.patch
@@ -0,0 +1,24 @@
+--- curl-7.86.0/lib/Makefile.am.orig 2022-10-29 12:03:24 +0000
++++ curl-7.86.0/lib/Makefile.am 2022-10-29 12:05:35 +0000
+@@ -107,7 +107,8 @@
+ endif
+
+ if USE_CPPFLAG_CURL_STATICLIB
+-libcurl_la_CPPFLAGS_EXTRA += -DCURL_STATICLIB
++libcurl_la_CPPFLAGS_EXTRA += -DCURL_STATICLIB -DNGHTTP2_STATICLIB
++libcurl_la_CFLAGS_EXTRA += -DNGHTTP2_STATICLIB
+ else
+ if OS_WINDOWS
+ libcurl_la_SOURCES += $(LIB_RCFILES)
+@@ -124,9 +125,9 @@
+ libcurl_la_LDFLAGS = $(AM_LDFLAGS) $(libcurl_la_LDFLAGS_EXTRA) $(LDFLAGS) $(LIBCURL_LIBS)
+ libcurl_la_CFLAGS = $(AM_CFLAGS) $(libcurl_la_CFLAGS_EXTRA)
+
+-libcurlu_la_CPPFLAGS = $(AM_CPPFLAGS) -DCURL_STATICLIB -DUNITTESTS
++libcurlu_la_CPPFLAGS = $(AM_CPPFLAGS) -DCURL_STATICLIB -DNGHTTP2_STATICLIB -DUNITTESTS
+ libcurlu_la_LDFLAGS = $(AM_LDFLAGS) -static $(LIBCURL_LIBS)
+-libcurlu_la_CFLAGS = $(AM_CFLAGS)
++libcurlu_la_CFLAGS = $(AM_CFLAGS) -DNGHTTP2_STATICLIB
+
+ CHECKSRC = $(CS_$(V))
+ CS_0 = @echo " RUN " $@;