summarylogtreecommitdiffstats
path: root/0002-nghttp2-static.patch
diff options
context:
space:
mode:
Diffstat (limited to '0002-nghttp2-static.patch')
-rw-r--r--0002-nghttp2-static.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/0002-nghttp2-static.patch b/0002-nghttp2-static.patch
new file mode 100644
index 000000000000..f2b067583e56
--- /dev/null
+++ b/0002-nghttp2-static.patch
@@ -0,0 +1,20 @@
+--- curl-7.61.0/lib/Makefile.am.orig 2018-07-26 11:45:27.548145800 +0300
++++ curl-7.61.0/lib/Makefile.am 2018-07-26 11:49:05.823729200 +0300
+@@ -111,7 +111,7 @@
+ endif
+
+ if USE_CPPFLAG_CURL_STATICLIB
+-libcurl_la_CPPFLAGS_EXTRA += -DCURL_STATICLIB
++libcurl_la_CPPFLAGS_EXTRA += -DCURL_STATICLIB -DNGHTTP2_STATIC
+ endif
+
+ if DOING_CURL_SYMBOL_HIDING
+@@ -123,7 +123,7 @@
+ libcurl_la_LDFLAGS = $(AM_LDFLAGS) $(libcurl_la_LDFLAGS_EXTRA) $(LDFLAGS) $(LIBCURL_LIBS)
+ libcurl_la_CFLAGS = $(AM_CFLAGS) $(libcurl_la_CFLAGS_EXTRA)
+
+-libcurlu_la_CPPFLAGS = $(AM_CPPFLAGS) -DCURL_STATICLIB -DUNITTESTS
++libcurlu_la_CPPFLAGS = $(AM_CPPFLAGS) -DCURL_STATICLIB -DNGHTTP2_STATIC -DUNITTESTS
+ libcurlu_la_LDFLAGS = $(AM_LDFLAGS) -static $(LIBCURL_LIBS)
+ libcurlu_la_CFLAGS = $(AM_CFLAGS)
+