summarylogtreecommitdiffstats
path: root/0003-Don-t-build-the-main-poppler-library.patch
diff options
context:
space:
mode:
Diffstat (limited to '0003-Don-t-build-the-main-poppler-library.patch')
-rw-r--r--0003-Don-t-build-the-main-poppler-library.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/0003-Don-t-build-the-main-poppler-library.patch b/0003-Don-t-build-the-main-poppler-library.patch
new file mode 100644
index 000000000000..93bdf4d8e20f
--- /dev/null
+++ b/0003-Don-t-build-the-main-poppler-library.patch
@@ -0,0 +1,40 @@
+From 91a177cd37e966653cc2c9ee401dbab5847f92e1 Mon Sep 17 00:00:00 2001
+From: Paul Gideon Dann <pdgiddie@gmail.com>
+Date: Tue, 20 Oct 2009 18:32:35 +0100
+Subject: [PATCH 3/3] Don't build the main poppler library.
+
+---
+ CMakeLists.txt | 17 -----------------
+ 1 file changed, 17 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 855ed842..b232915e 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -544,23 +544,6 @@ ADD_GPERF_FILE(TimesItalicWidths)
+ ADD_GPERF_FILE(TimesRomanWidths)
+ ADD_GPERF_FILE(ZapfDingbatsWidths)
+
+-if(MSVC)
+-add_definitions(-D_CRT_SECURE_NO_WARNINGS)
+-add_library(poppler STATIC ${poppler_SRCS})
+-else()
+-add_library(poppler ${poppler_SRCS})
+-endif()
+-set_target_properties(poppler PROPERTIES VERSION 101.0.0 SOVERSION 101)
+-if(MINGW AND BUILD_SHARED_LIBS)
+- get_target_property(POPPLER_SOVERSION poppler SOVERSION)
+- set_target_properties(poppler PROPERTIES SUFFIX "-${POPPLER_SOVERSION}${CMAKE_SHARED_LIBRARY_SUFFIX}")
+-endif()
+-target_link_libraries(poppler LINK_PRIVATE ${poppler_LIBS})
+-if(CMAKE_USE_PTHREADS_INIT)
+- target_link_libraries(poppler LINK_PRIVATE Threads::Threads)
+-endif()
+-install(TARGETS poppler RUNTIME DESTINATION bin LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR} ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR})
+-
+ if(ENABLE_UNSTABLE_API_ABI_HEADERS)
+ install(FILES
+ poppler/Annot.h
+--
+2.27.0
+