summarylogtreecommitdiffstats
path: root/0003-ZEN-Add-OpenRGB-patches.patch
diff options
context:
space:
mode:
Diffstat (limited to '0003-ZEN-Add-OpenRGB-patches.patch')
-rw-r--r--0003-ZEN-Add-OpenRGB-patches.patch17
1 files changed, 7 insertions, 10 deletions
diff --git a/0003-ZEN-Add-OpenRGB-patches.patch b/0003-ZEN-Add-OpenRGB-patches.patch
index 104f5cb62efc..f83fedafc70f 100644
--- a/0003-ZEN-Add-OpenRGB-patches.patch
+++ b/0003-ZEN-Add-OpenRGB-patches.patch
@@ -41,10 +41,10 @@ Date: Wed Jun 17 14:24:20 2020 -0500
create mode 100644 drivers/i2c/busses/i2c-nct6775.c
diff --git a/drivers/i2c/busses/Kconfig b/drivers/i2c/busses/Kconfig
-index 8a6c6ee28556..cf4c5e92738b 100644
+index a1bae59208e346572063dc8a16fe8b9c89ecf583..901471a36cab097b6f30d03a82f7546ff2985b6b 100644
--- a/drivers/i2c/busses/Kconfig
+++ b/drivers/i2c/busses/Kconfig
-@@ -219,6 +219,15 @@ config I2C_CHT_WC
+@@ -227,6 +227,15 @@ config I2C_CHT_WC
combined with a FUSB302 Type-C port-controller as such it is advised
to also select CONFIG_TYPEC_FUSB302=m.
@@ -61,10 +61,10 @@ index 8a6c6ee28556..cf4c5e92738b 100644
tristate "Nvidia nForce2, nForce3 and nForce4"
depends on PCI
diff --git a/drivers/i2c/busses/Makefile b/drivers/i2c/busses/Makefile
-index 1d00dce77098..ec8a1197c8bc 100644
+index 479f60e4ee3d6f6e0715fba000a4f70f8ec4c932..e8f6d8b41781cbc39a3c785ba02abbec7791bf74 100644
--- a/drivers/i2c/busses/Makefile
+++ b/drivers/i2c/busses/Makefile
-@@ -17,6 +17,7 @@ obj-$(CONFIG_I2C_CHT_WC) += i2c-cht-wc.o
+@@ -20,6 +20,7 @@ obj-$(CONFIG_I2C_CHT_WC) += i2c-cht-wc.o
obj-$(CONFIG_I2C_I801) += i2c-i801.o
obj-$(CONFIG_I2C_ISCH) += i2c-isch.o
obj-$(CONFIG_I2C_ISMT) += i2c-ismt.o
@@ -74,7 +74,7 @@ index 1d00dce77098..ec8a1197c8bc 100644
obj-$(CONFIG_I2C_NVIDIA_GPU) += i2c-nvidia-gpu.o
diff --git a/drivers/i2c/busses/i2c-nct6775.c b/drivers/i2c/busses/i2c-nct6775.c
new file mode 100644
-index 000000000000..0462f0952043
+index 0000000000000000000000000000000000000000..0462f0952043112cddf1b1fcacbf777dfd358bca
--- /dev/null
+++ b/drivers/i2c/busses/i2c-nct6775.c
@@ -0,0 +1,647 @@
@@ -726,10 +726,10 @@ index 000000000000..0462f0952043
+module_init(i2c_nct6775_init);
+module_exit(i2c_nct6775_exit);
diff --git a/drivers/i2c/busses/i2c-piix4.c b/drivers/i2c/busses/i2c-piix4.c
-index 8c1b31ed0c42..0b1b36fa0b71 100644
+index ac8e7d60672a1b49322cbfeb85c9e96015de7b45..79057903415ad8fe3c9708f817b87f8ffac3cd7d 100644
--- a/drivers/i2c/busses/i2c-piix4.c
+++ b/drivers/i2c/busses/i2c-piix4.c
-@@ -467,11 +467,11 @@ static int piix4_transaction(struct i2c_adapter *piix4_adapter)
+@@ -570,11 +570,11 @@ static int piix4_transaction(struct i2c_adapter *piix4_adapter)
if (srvrworks_csb5_delay) /* Extra delay for SERVERWORKS_CSB5 */
usleep_range(2000, 2100);
else
@@ -743,6 +743,3 @@ index 8c1b31ed0c42..0b1b36fa0b71 100644
/* If the SMBus is still busy, we give up */
if (timeout == MAX_TIMEOUT) {
---
-2.35.1
-