summarylogtreecommitdiffstats
path: root/0003-cmake-use-native-antlr.patch
diff options
context:
space:
mode:
Diffstat (limited to '0003-cmake-use-native-antlr.patch')
-rw-r--r--0003-cmake-use-native-antlr.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/0003-cmake-use-native-antlr.patch b/0003-cmake-use-native-antlr.patch
new file mode 100644
index 000000000000..5c9c1ecd3967
--- /dev/null
+++ b/0003-cmake-use-native-antlr.patch
@@ -0,0 +1,27 @@
+From 501df447d4d3c7f4e22f4fec43b4915b8de2013c Mon Sep 17 00:00:00 2001
+From: Xiretza <xiretza@xiretza.xyz>
+Date: Sat, 4 Jun 2022 11:32:32 +0200
+Subject: [PATCH 3/7] cmake: use native antlr
+
+---
+ src/CMakeLists.txt | 4 ----
+ 1 file changed, 4 deletions(-)
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index caf428a..f4b5b1f 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -55,10 +55,6 @@ endif()
+ # add antrl4cpp artifacts to project environment
+ include_directories(${ANTLR4_INCLUDE_DIRS})
+
+-# set variable pointing to the antlr tool that supports C++
+-# this is not required if the jar file can be found under PATH environment
+-set(ANTLR_EXECUTABLE ${CMAKE_CURRENT_SOURCE_DIR}/../third_party/antlr4_lib/antlr-4.9.3-complete.jar)
+-
+ # add macros to generate ANTLR Cpp code from grammar
+ find_package(ANTLR REQUIRED)
+
+--
+2.36.1
+