summarylogtreecommitdiffstats
path: root/0003-fix-cmake-targets.patch
diff options
context:
space:
mode:
Diffstat (limited to '0003-fix-cmake-targets.patch')
-rw-r--r--0003-fix-cmake-targets.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/0003-fix-cmake-targets.patch b/0003-fix-cmake-targets.patch
new file mode 100644
index 000000000000..620b8bc78ecd
--- /dev/null
+++ b/0003-fix-cmake-targets.patch
@@ -0,0 +1,19 @@
+--- c-ares-cares-1_13_0/CMakeLists.txt.orig 2017-11-14 10:37:45.399929800 +0300
++++ c-ares-cares-1_13_0/CMakeLists.txt 2017-11-14 10:40:39.555223600 +0300
+@@ -545,6 +545,7 @@
+ EXPORT_NAME cares
+ OUTPUT_NAME cares
+ VERSION "${CARES_LIB_VERSION_MAJOR}.${CARES_LIB_VERSION_MINOR}.${CARES_LIB_VERSION_RELEASE}"
++ RUNTIME_OUTPUT_NAME cares-${CARES_LIB_VERSION_AGE}
+ SOVERSION "${CARES_LIB_VERSION_MAJOR}"
+ )
+
+@@ -574,7 +575,7 @@
+
+ SET_TARGET_PROPERTIES (${LIBNAME} PROPERTIES
+ EXPORT_NAME cares${STATIC_SUFFIX}
+- OUTPUT_NAME cares${STATIC_SUFFIX}
++ OUTPUT_NAME cares
+ )
+
+ IF (CARES_STATIC_PIC)