summarylogtreecommitdiffstats
path: root/0003-swift-python2-as-fallback-only.patch
diff options
context:
space:
mode:
Diffstat (limited to '0003-swift-python2-as-fallback-only.patch')
-rw-r--r--0003-swift-python2-as-fallback-only.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/0003-swift-python2-as-fallback-only.patch b/0003-swift-python2-as-fallback-only.patch
new file mode 100644
index 000000000000..f85ab214d40b
--- /dev/null
+++ b/0003-swift-python2-as-fallback-only.patch
@@ -0,0 +1,25 @@
+From a20416f07c26b8dbb62b0b0b2b51d47f658cc1b2 Mon Sep 17 00:00:00 2001
+From: soloturn <soloturn@gmail.com>
+Date: Sat, 11 Jul 2020 04:26:10 +0200
+Subject: [PATCH] swift python2 as fallback only
+
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index c8f9999c2a..df2da5e731 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -889,7 +889,7 @@ if(NOT CMAKE_SYSTEM_NAME STREQUAL "Darwin")
+ endif()
+ endif()
+
+-find_package(Python2 COMPONENTS Interpreter REQUIRED)
++find_package(Python2 COMPONENTS Interpreter)
+ find_package(Python3 COMPONENTS Interpreter)
+ if(NOT Python3_Interpreter_FOUND)
+ message(WARNING "Python3 not found, using python2 as a fallback")
+--
+2.27.0
+