summarylogtreecommitdiffstats
path: root/0004-Don-t-build-the-main-poppler-library.patch
diff options
context:
space:
mode:
Diffstat (limited to '0004-Don-t-build-the-main-poppler-library.patch')
-rw-r--r--0004-Don-t-build-the-main-poppler-library.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/0004-Don-t-build-the-main-poppler-library.patch b/0004-Don-t-build-the-main-poppler-library.patch
new file mode 100644
index 000000000000..d41152f3dd44
--- /dev/null
+++ b/0004-Don-t-build-the-main-poppler-library.patch
@@ -0,0 +1,34 @@
+From 10b74e97a67520b7405f37cc65b90d8ed0fedbc2 Mon Sep 17 00:00:00 2001
+From: Paul Gideon Dann <pdgiddie@gmail.com>
+Date: Tue, 20 Oct 2009 18:32:35 +0100
+Subject: [PATCH 4/4] Don't build the main poppler library.
+
+---
+ CMakeLists.txt | 11 -----------
+ 1 file changed, 11 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 98d23a61..37aecf7e 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -530,17 +530,6 @@ if(HAVE_PTHREAD)
+ set(poppler_LIBS ${poppler_LIBS} ${CMAKE_THREAD_LIBS_INIT})
+ endif()
+
+-if(MSVC)
+-add_definitions(-D_CRT_SECURE_NO_WARNINGS)
+-set(CMAKE_CXX_FLAGS "/Zc:wchar_t- ${CMAKE_CXX_FLAGS}")
+-add_library(poppler STATIC ${poppler_SRCS})
+-else(MSVC)
+-add_library(poppler SHARED ${poppler_SRCS})
+-endif(MSVC)
+-set_target_properties(poppler PROPERTIES VERSION 67.0.0 SOVERSION 67)
+-target_link_libraries(poppler LINK_PRIVATE ${poppler_LIBS})
+-install(TARGETS poppler RUNTIME DESTINATION bin LIBRARY DESTINATION lib${LIB_SUFFIX} ARCHIVE DESTINATION lib${LIB_SUFFIX})
+-
+ if(ENABLE_XPDF_HEADERS)
+ install(FILES
+ poppler/Annot.h
+--
+2.13.1
+