summarylogtreecommitdiffstats
path: root/0004-Fix-transitive-dependencies-of-static-libraries.patch
diff options
context:
space:
mode:
Diffstat (limited to '0004-Fix-transitive-dependencies-of-static-libraries.patch')
-rw-r--r--0004-Fix-transitive-dependencies-of-static-libraries.patch52
1 files changed, 25 insertions, 27 deletions
diff --git a/0004-Fix-transitive-dependencies-of-static-libraries.patch b/0004-Fix-transitive-dependencies-of-static-libraries.patch
index f149c1cb73d5..42596efe94dc 100644
--- a/0004-Fix-transitive-dependencies-of-static-libraries.patch
+++ b/0004-Fix-transitive-dependencies-of-static-libraries.patch
@@ -1,4 +1,4 @@
-From f0176a1ae2e36b4ea89bda4a927bf387a4e20ead Mon Sep 17 00:00:00 2001
+From c037501e09603ef9ab645b0f9c909acb693ac096 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Thu, 5 Nov 2020 21:59:33 +0100
Subject: [PATCH 4/7] Fix transitive dependencies (of static libraries)
@@ -7,17 +7,17 @@ The dependencies of these libraries are not reliably picked up by their
corresponding find modules. This change allows adding the required
dependencies by setting certain variables, e.g. within the toolchain file.
-Change-Id: I89da5ef519dd6dd3f86a94a01d3da7208a070bdb
+Change-Id: I81dbe9eebf1529116417c5bf5332b3f135e854bd
---
- .../3rdparty/extra-cmake-modules/find-modules/FindGLIB2.cmake | 2 +-
- cmake/FindMySQL.cmake | 1 +
- cmake/FindWrapDBus1.cmake | 3 ++-
- cmake/FindWrapOpenSSL.cmake | 2 +-
- cmake/FindWrapSystemFreetype.cmake | 2 +-
- cmake/FindWrapSystemHarfbuzz.cmake | 2 +-
- cmake/FindWrapSystemPNG.cmake | 2 +-
- src/plugins/sqldrivers/psql/CMakeLists.txt | 2 +-
- 8 files changed, 9 insertions(+), 7 deletions(-)
+ cmake/3rdparty/extra-cmake-modules/find-modules/FindGLIB2.cmake | 2 +-
+ cmake/FindMySQL.cmake | 1 +
+ cmake/FindWrapDBus1.cmake | 1 +
+ cmake/FindWrapOpenSSL.cmake | 2 +-
+ cmake/FindWrapSystemFreetype.cmake | 2 +-
+ cmake/FindWrapSystemHarfbuzz.cmake | 2 +-
+ cmake/FindWrapSystemPNG.cmake | 2 +-
+ src/plugins/sqldrivers/psql/CMakeLists.txt | 2 +-
+ 8 files changed, 8 insertions(+), 6 deletions(-)
diff --git a/cmake/3rdparty/extra-cmake-modules/find-modules/FindGLIB2.cmake b/cmake/3rdparty/extra-cmake-modules/find-modules/FindGLIB2.cmake
index 8f873c1b45..831ca8e624 100644
@@ -33,29 +33,27 @@ index 8f873c1b45..831ca8e624 100644
endif()
diff --git a/cmake/FindMySQL.cmake b/cmake/FindMySQL.cmake
-index 54c94b8a2f..7575386338 100644
+index f6c77d2be1..c20e7c9fa5 100644
--- a/cmake/FindMySQL.cmake
+++ b/cmake/FindMySQL.cmake
-@@ -38,6 +38,7 @@ if(MySQL_FOUND AND NOT TARGET MySQL::MySQL)
- add_library(MySQL::MySQL UNKNOWN IMPORTED)
- set_target_properties(MySQL::MySQL PROPERTIES
- IMPORTED_LOCATION "${MySQL_LIBRARIES}"
-+ INTERFACE_LINK_LIBRARIES "${MYSQL_DEPENDENCIES}"
- INTERFACE_INCLUDE_DIRECTORIES "${MySQL_INCLUDE_DIRS}")
+@@ -37,6 +37,7 @@ if(MySQL_FOUND AND NOT TARGET MySQL::MySQL)
+ add_library(MySQL::MySQL UNKNOWN IMPORTED)
+ set_target_properties(MySQL::MySQL PROPERTIES
+ IMPORTED_LOCATION "${MySQL_LIBRARIES}"
++ INTERFACE_LINK_LIBRARIES "${MYSQL_DEPENDENCIES}"
+ INTERFACE_INCLUDE_DIRECTORIES "${MySQL_INCLUDE_DIRS}")
endif()
diff --git a/cmake/FindWrapDBus1.cmake b/cmake/FindWrapDBus1.cmake
-index 4982e7c8ae..56d139c538 100644
+index bdbcab9eb3..06e9af49f6 100644
--- a/cmake/FindWrapDBus1.cmake
+++ b/cmake/FindWrapDBus1.cmake
-@@ -45,4 +45,5 @@ include(FindPackageHandleStandardArgs)
- find_package_handle_standard_args(WrapDBus1 REQUIRED_VARS
- DBus1_LIBRARY DBus1_INCLUDE_DIR WrapDBus1_FOUND
+@@ -47,4 +47,5 @@ find_package_handle_standard_args(WrapDBus1 REQUIRED_VARS
VERSION_VAR DBus1_VERSION)
--set_property(TARGET dbus-1 PROPERTY IMPORTED_IMPLIB ${DBus1_LIBRARY})
-\ No newline at end of file
-+set_property(TARGET dbus-1 PROPERTY IMPORTED_IMPLIB ${DBus1_LIBRARY})
-+set_property(TARGET dbus-1 PROPERTY INTERFACE_LINK_LIBRARIES "${DBUS1_DEPENDENCIES}")
+ if(TARGET dbus-1)
+ set_property(TARGET dbus-1 PROPERTY IMPORTED_IMPLIB ${DBus1_LIBRARY})
++ set_property(TARGET dbus-1 PROPERTY INTERFACE_LINK_LIBRARIES "${DBUS1_DEPENDENCIES}")
+ endif()
diff --git a/cmake/FindWrapOpenSSL.cmake b/cmake/FindWrapOpenSSL.cmake
index 6e80862258..47bea72aad 100644
--- a/cmake/FindWrapOpenSSL.cmake
@@ -122,5 +120,5 @@ index 62e9619d16..939163bde7 100644
Qt::CorePrivate
Qt::SqlPrivate
--
-2.29.2
+2.30.0